as my title says, I have problems regarding the loading time of my website.

If I visit it as a guest, it's very fast but when I try to do the same loggin-in, I notice a very long time increase in the loading of the webpage. This happens to EVERY page on my Joomla website, I use K2, Jotcache and JCH Optimize. I also use Cloudflare as a CDN.

My website is http://sbenny.com

In my opinion, it looks like the website is not cached for registered Users but I'm not sure about it. If this is what's really happening, is there a way to prevent this? If not, what else should I try? I'm actually on a Shared Hosting Service but it's quite fast (less than 0.7s to completely render a webpage for guests)

Thank you for your time.

  • Have you got any extensions that are only enabled for registered users?
    – Lodder
    Mar 5, 2015 at 10:01
  • Yes, only one. I try disabling it and I'll let you know in 5 mins.
    – v3ntus
    Mar 5, 2015 at 10:09
  • It looks my website is about 20% faster now for registered users. The problem is, this Extension MUST be enabled only for registered users and NOT for guests. Is there a way to cache this extensions if used only by registered users?
    – v3ntus
    Mar 5, 2015 at 10:21
  • In JCH, there is an option to exclude JS/CSS files. Try excluding the files used by this extension
    – Lodder
    Mar 5, 2015 at 10:23
  • I'm not getting it. You mean JCH? If yes, shouldn't I include the files instead of excluding them?
    – v3ntus
    Mar 5, 2015 at 10:24

2 Answers 2


your problem might be in caching as you are using jch, i suggest you read the manual for jch to understand how it works. But to tell you in brief, if you have a js script that changes everytime the page loads or when a user interacts with the page then this will affect the .js file created by jch which will be changed forcing the browser to download it everytime(i.e no cach) you need to figure out which script is causing this. please READ THIS as it explains how to figure out which script is casuing this.



JotCache extension follows the same basic rules as System-Cache in Joomla core. Here are allowed only pages for non-registred users to be cached in Joomla cache. For registred users is JotCache not active (per design). The major reason for this behavior is dynamic nature of most activities of registred users.

  • Looks like I should try using JotCache, they've done lots of improvements since I last used it. Including on the stuff that used to give head aches. Mar 5, 2015 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.