6

I tired more then hours,but i could not find the solutions for this issue. i have site with Joomla 3.4. i have move the files to my local system. config the data base and other things, but page show error below.

Error displaying the error page: Could not find template "".: Could not find template "".

My config of db

public $dbtype = 'mysql';
public $host = 'localhost';
public $user = 'root';
public $password = 'user15';

please tell me how can resolve this issue.

  • 1
    Can you access the backend? If so try logging in and changing the default template so it can display the actual error message. This error is saying that it cannot even display the error because the template can't be found. – Wasim Mar 4 '15 at 12:00
  • Sorry, i cant logged in backend... – Raj Mohan Mar 4 '15 at 12:05
  • Have your '/tmp' and '/log' file paths changed since the move? Also have your permissions changed any? – jonboy Mar 4 '15 at 12:27
  • 1
    Goto the #__template_styles table and change the default template to Beez3. See if the template displays then. – Wasim Mar 4 '15 at 12:37
  • one more thing, i tried to install vermilion theme in 3.4 joomla,just white screen displayed and theme is not installed. – Raj Mohan Mar 6 '15 at 6:27
4

If your original website worked fine, and your localhost copy don't work, it's probable that something went wrong in the restoration process. Either some files are missing, or the database is incorrectly restored.

Here's a couple of things you can try in order to fix your website:

  • If possible, download the original website again. Use Akeeba Backup to make a backup, then download it and restore it to your localhost environment using Akeeba Kickstart. Akeeba Backup will include all your files AND your database in one single file, and also includes a restoration script that helps you set up your configuration.php file correctly.

  • If that doesn't work, try unzipping the full version of Joomla 3.4 into your existing Joomla directory, replacing any existing files. Then remove the installation folder.

  • Thank its working,the downloading backup is corrupted issue. – Raj Mohan Mar 5 '15 at 5:05
  • Great, I'm glad you solved it. Corrupt backup or wrong .htaccess configuration are among the most common reasons when a copy of a working site breaks. – johanpw Mar 5 '15 at 13:59
  • yes,but my sql files are corrupted some of the table is not exact. – Raj Mohan Mar 6 '15 at 6:24
2

For me this happened because I had not exported the database properly, that is there were no data just the shell of tables.

So just ensure that insert statements exist in your sql statements and by the way.. it not good to post your passwords and usernames here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.