5

I am not able to send email using gmail as SMTP. I have already tried using the following settings in the Joomla backend:

  • SMTP Authentication = Yes
  • SMTP Security = SSL
  • SMTP Port = 465
  • SMTP Username = [respective mail id]
  • SMTP Password = xxxxxx
  • SMTP Host = smtp.gmail.com

I have built Koomla site on localhost and I'm trying to send email using smtp.gmail.com. Though port 465 is enabled still its not working.

Can you tell me what the issue might be?

  • Have you tried SMTP Security: TLS and SMTP Port 587. Do you use two step authentication on Gmail by any chance? – jonboy Apr 20 '15 at 8:27
  • I can confirm Brijesh's solution. After changing the switch Allow Less Secure Apps to ON Joomla mail function began working again. Previously using SMTP to send via Google Apps for Work was not working. After changing the switch, tested successfully using port 465/SSL and 587/TLS. – user8082 Mar 23 '16 at 18:03
1

Try these settings :

Mailer : SMTP Server
Mail from : youremail@yourdomain ( Write your e-mail here )
From Name : My Name ( Write a normal name here )
Sendmail Path : leave it by default 
SMTP Authentication : No
SMTP Security : None
SMTP Port : 25
SMTP Username : youremail@yourdmain ( Your Full e-mail address )
SMTP Password : YourEmailPassword
SMTP Host : gmail-smtp-in.l.google.com 

Be sure to Enable the ( Authentication - GMail ) plugin

go to your Admin Area,

Extensions --> Plugin Manager --> Authentication - GMail

1

Sign-in with your google account, and Click Here

now on the bottom right you will find Allow less secure apps: OFF Some non-Google apps and devices use less secure sign-in technology, which could leave your account vulnerable. You can turn off access for these apps (which we recommend) or choose to use them despite the risks.

Turn it on and now you will be able to authenticate through your email account and send mails from your joomla website.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.