0

This is completely annoying... I have enabled gzip compression in Joomla system configuration I have also enabled gzip compression in the htaccess file... But every time I test http://ganeshgrow.es in websites like GTmetrix or Google Insights, they tell me that the 70% can be compressed for a better perfomance... So...? What should I do?

1

You are compressing the main html Joomla output and files delivered from your site. However, your site may be including more files from other sources.

To debug it, you can inspect how your page loads network resources, with Firebug or Chrome dev tools (F12), to detect uncompressed assets.

| improve this answer | |
  • Mmmm I don't understand exactly what I have to do – Antonio Feb 17 '15 at 16:29
  • You have to check all http headers, of all loaded assets from your page, to discover what is not compressed. – Anibal Feb 17 '15 at 16:47
  • You mean this: gyazo.com/0dc92758a9782b9bc7a955bbc2950089 ?? – Antonio Feb 17 '15 at 17:13
  • You have inspect network activity (look for Content-Encoding header). For instance, with Firebug getfirebug.com/network – Anibal Feb 17 '15 at 17:32
  • I have gzip, but if i check it with a tester, it tells me that i dont have it enabled – Antonio Feb 17 '15 at 17:54
0

There are quite a few things you can do.

For starters, have a look at the information that GTMatrix provides you:

  • Serve scaled images. When using images on websites, make sure they are always scaled down to the minimum size you need. You should also saves images as Web Version which simply means the quality is slightly reduces but the so is the size of the file, and drastically too. If you have Photoshop or Gimp, then make full use of them.
  • Defer parsing of JavaScript. If I rightly remember, you're using JCE Optimize, which has the option to defer your Javascript.
  • *Leverage browser caching. For more information on how to improve this, have a look at this
  • Combine images using CSS sprites. When using a CMS, this can be quite hard as most of the images will belong to other extensions, however, again, with JCE Optimize, there's an option to convert all images into a sprite, so try enabling this option.
  • Avoide CSS @import. As you may notice from the results, some of your CSS files are using @import url('URL HERE');. Instead of doing this, CSS files are better off being imported through the <head> tag.
| improve this answer | |
  • When I enable the CSS sprites option from JCH Optimize, the CSS of my website breaks. It happens the same when I try to put all my css/js files in just one... and I'm sure the website is slow because of all the files it's trying to load... So... I really don't know what to do – Antonio Feb 17 '15 at 17:28
  • I have been thinking... My website is probably slow because of the JS files that it's trying to load BEFORE page does... So... what about moving all the js files to the bottom of the page...? I can't move it with JCH Optimize, because I can't compress the js files. It returns me an error... So I downloaded ScriptDown plugin... and when I press F5... gyazo.com/d2b4ff043774cb52967df85b12aca1fc – Antonio Feb 18 '15 at 10:16
0

Your web server must also be configured to allow this. If it doesn't have mod_deflate installed then no matter how many times you ask it to gzip the output, it isn't going to.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.