A joomla website is throwing a 404 error, when I try to access it root page /index.php, but when I deactivate the joomla built-in sef plugin, the website is accessed normally (code 200). I have tried to clear my .htaccess but the error persists. I wonder if I have to change anything in my sef plugin code?

I have also some strange redirection on the /administrator page when I change some configuration & save, the page redirected to have 'http' just after host name: http://hostname/httpadministrator. But because the redirection is not coming from my .htaccess I cant debug it with RewriteLog.

I'm suspecting the `sef builtin plugin``. Does anyone know what can be the source of this issue?

P.S: I'm using Joomla 2.5 with K2.

  • you should really ask your host because they will know your environment and hardware and if they are any good have had to figure this out tons of times already. It will be difficult for anyone to give you anything but shot-in-the-dark answers to solve this. May 15, 2014 at 22:13

2 Answers 2


Maybe this can help you: http://docs.joomla.org/Enabling_Search_Engine_Friendly_%28SEF%29_URLs

Try to comment out Options +FollowSymLinks in the htaccess file.

  • Commenting Options +FollowSymLinks hadnt resolved it.
    – Hakim
    May 17, 2014 at 13:28
  • And you follow the other instructions in the provided link? May 17, 2014 at 13:30
  • Yep it hadnt resolved my problem. What I found strange is the http string concatenated to the url when I try to save inside the /administrator.
    – Hakim
    May 17, 2014 at 14:26
  • Who is the Webhoster? 99% of my own and client sites need only to rename the htaccess.txt to .htaccess and then comment out the rewritebase / setting and then to activate the sef settings in the joomla global configuration menu. Maybe this is a hoster problem. May 17, 2014 at 15:00

It was just the browser proxy that was redirecting to an ugly url that joomla's router couldnt translate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.