1

in one of my component record entry form i placed a editor which use tinymce from joomla configuration. i save record by entering some texts for a description field like "description description description description description description description" which as u see i placed a space after each word in editor by pressing keyboard space key.

but when it is displayed in front end, text does not break on space upon exceeding the width in percent in table td so is it's showing text crossing the limit of my table width to right breaking template width.

So are those actually spaces when texts added with space via tinymce editor??. When i add text manually in front end component view file without outputting description field then i see text breaks in space. I checked mysql database table too for description field and don't see any characters replaced space.

So where is the problem when i display text in front end with space entered by tinymce editor at backend that it do not break in space upon width limit exceeded??

  • Do you have the Entity Encoding set to raw – Lodder May 14 '14 at 16:39
  • Where? If in editor plugin settings then all are set as default but line break as <br> and advanced parameters.but all i will check soon as offline now. – dev-m May 14 '14 at 17:01
  • 1
    Have you checked the html output on your browser in conjunction with the css? – FFrewin May 14 '14 at 18:53
  • @Lodder entity encoding in plugin settings set to raw.It's look like a global problem as i created a joomla default article and displayed in front end, same behaviour too. – dev-m May 14 '14 at 20:38
  • Is this limited to tinyMCE entries or have you tried another editor like JCE? – BodgeIT May 15 '14 at 6:19
2

Have you tried jce editor? I always replace the default with this one and work s fine for me. https://www.joomlacontenteditor.net/

1

It is possible that your CSS code contains white-space: nowrap; somewhere, thus forcing the text to be displayed in a single line within your table.

You should also check your source code to see if the text

description description description description description description description

is rendered within <pre> tags.

I hope this helps you find your solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.