I have a client with an old Joomla 1.5 they dont want to upgrade this year but their host wants to upgrade the server. What is the maximum version of php that Joomla 1.5 will run rather than the min that is listed?

Joomla! versions 1.5.15 and later are compatible with PHP 5.3.

Would it run ok on 5.3.10? I would guess it would break on 5.4 but I find it hard to build a test machine with old versions to test. So more question from experience.


  • Please dont point out I should upgrade it though as there is a different budget for that later, thanx May 12, 2014 at 20:49
  • But a small advice: Maybe a small WAF(Web Application Firewall) like AdminToolsPro can save much of your time and money :-) May 13, 2014 at 19:01

3 Answers 3


If you're running Joomla 1.5.14 or below then you should stick to PHP 5.2 as there may be a few functions and/or code snippets that may not work on PHP 5.3

However, if you're running Joomla 1.5.15 or above, you should be fine with upgrading to PHP 5.3. If you're using the OpenID library, then this won't be compatible with PHP 5.3 and thus you will either need to find an alternative or stick with PHP 5.2

For more information on which versions of PHP, MySQL and Apache, have a look at theTechnical Requirements

I would suggest you upgrade to Joomla 1.5.26 which is the latest version of the 1.5 series.

Hope this helps

  • 2
    I have a few Joomla 1.5.26 websites running fine on Joomla 5.4. although I did need to disable the strict standard errors as per stackoverflow.com/a/9984309 May 12, 2014 at 23:47
  • 2
    Don't forget the unofficial security patch: anything-digital.com/blog/security-updates/joomla-updates/… May 13, 2014 at 8:04
  • 1
    I have quite a few Joomla 1.5.26 patched / 1.5.999 sites running on php 5.4.28, just disabled the strict warnings. May 13, 2014 at 8:54
  • 2
    Omly Joomla 1.0 has problems with PHP 5.3 (there is a unofficial patch to use J1.0 with PHP5.3) and Joomla 1.5 work with PHP 5.4.x. May 13, 2014 at 9:25
  • 1
    The project hasn't officially tested 1.5 on PHP 5.4 so we don't make the statement that it is supported. This is why PHP 5.3 is the recommendation.
    – Michael
    May 13, 2014 at 18:29

I'm running a Joomla 1.5.26 site alongside a new J3 site under construction on the same PHP installation. The J1.5 site is running perfectly on PHP 5.6 without any changes to anything at all. The J1.5 site is a very simple site with only a few extensions.

  • Yes, sorry it should read 1.5.26.
    – biltong
    May 15, 2016 at 10:38
  • Just confirming I now have several varied Joomla 1.5.26 websites running fine on PHP 5.6. Mar 8, 2017 at 2:49

I confirm Joomla 1.5.24 running on PHP 5.5.9-1ubuntu4.17. PHP-FPM was installed with apt. Web server is nginx. All features seems to be running smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.