After installing JCE 2.4.6 on Joomla 3.3.6, when entering edit mode my Apache2.4 installed by XAMPP 3.2.1 crashes

After disabling compression setting in JCE Administration :: Editor Global Configuration, it just works fine.

enter image description here Is there any way to enable it?

  • Have you considered reaching out to the extension developer? While there may be someone in this community with experience in this extension, your best bet is to follow up with the developer directly.
    – Lodder
    Commented Feb 16, 2015 at 15:24
  • I'm not 100% sure, but I always considered those options to be relative to your backend / frontend editing. I don't think they affect your site's frontend; so disabling it won't hurt your users. Commented Feb 16, 2015 at 20:15
  • Hi, happened to me at with various Apache versions as well. Try installing Apache, MySQL, PHP separately and try different apache versions. It could also be an apache module, not sure how you turn them off in XAMPP
    – jdog
    Commented Feb 21, 2015 at 6:26

3 Answers 3


Since you're using XAMPP, I assume you're developing the site on your local computer. There's no reason to compress CSS/Javascript (or use Gzip) on a local development site. It makes no noticeable difference, and debugging get's a lot harder.

Leave compression disabled until your site is ready, then try activating the settings on your online server and see if the problem still exists. If it does, you should contact the JCE developers, and probably your host as well.


As you are enabling compression of JavaScript and CSS files with Gzip. You need to make sure you have installed Apache module mod_deflate and the module is enabled. You can check this in phpinfo();

As enable of Gzip compression will add <IfModule mod_deflate.c> line to your .htaccess file. SO the module should be enabled to be used by Apache.

You can further check other modules used in .htaccess as well. I believe is the only reason of Apache crash.

Further discussion of check/install of mod_deflate is here


Compress CSS = No solved the problem in my case. Javascript and GZip compression can be ON.

JCE 2.5.16; Joomla 3.5.1; XAMPP 5.5.19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.