2

After uploading my Joomla! 3.3 from localhost, I got a very serious problem: the images on the website are not displayed!

When I tried accessing the URL of an image, I got an Internal Server Error. The images are well on the server, with chmod 644 (and 755 for the image folders).

Hope somebody can help.

Thank you in advance!

  • Because your website is located inside a subdirectory on your domain (example.com/home), it is possible that the parent directory contains a .htaccess-file. Rules in this file would also affect your Joomla site. Are you able to provide a link to your site? – johanpw Feb 13 '15 at 16:02
1

There seems to be something wrong with your images folder. If I visit http://example.com/media, I get the expected blank page (the empty index.html that is located inside each folder to avoid directory listing).

However, http://example.com/images gives a 500 error, so none of your images in that folder are available. The thumbnails show up because a plugin (plg_readlesstext) caches your images and creates a thumbnail in the cache folder, outside the images folder.

Check if you have a .htaccess file inside your images folder. If not, try disabling the Readless plugin and see if that makes any difference.

  • You are absolutely right!!! I created an .htaccess file in that folder yesterday, based on a suggestion of a person on Joomla!'s forum. (The content of the file is "php_flag engine off". That person said that this is more secure). I don't know if he's right but I have to remove it :P Thank you so much!!! – Khue Feb 13 '15 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.