1

After uploading my Joomla! 3.3.6 installation (that I had upgraded from 2.5 on localhost) on my Godaddy shared host, I cannot access the site: I got 500 Internal Server Error (after waiting for ~30 seconds).

When trying going to ACP, I could access the login page, however after entering the username/password, I got the same error.

I could not find any solutions that work, including this one.

The .htaccess file (located in Joomla! root) can be downloaded from here: http://www.mediafire.com/view/r63jowwxtb6skp5/htaccess

Hope somebody can help.

Thank you very much!

  • 1
    Works ok on localhost? – jonboy Feb 12 '15 at 21:44
  • Is your Joomla installation located in the /home directory, accessed by http://yourdomain.com/home/index.php? If not, you should change the line RewriteBase /home in your .htaccess file. – johanpw Feb 12 '15 at 23:09
  • @johnny_s: yes, works fine on localhost. I have an IPB forum hosted on the same server and it works just fine, so I think there's something wrong on the Joomla!'s side rather than the server's. – Khue Feb 12 '15 at 23:16
  • @johanpw: yes Joomla! installation is located in the /home directory. To be more specific, it is located in html_public/mydomain.com/home, where html_public/mydomain.com/ is the directory to which I point the domain, which is from another provider. – Khue Feb 12 '15 at 23:18
  • OK, but how do you access your website? If you use http://example.com/ then you should change that line to RewriteBase / in your htaccess file. This answer explains more about this. Try making the change and see if it makes any difference. – johanpw Feb 12 '15 at 23:46
1

It's often hard to find the reason for 500 Internal Server errors, but here's a couple of things you can check and/or test.

(Note: it has been reported that on GoDaddy, changes to .htaccess files need 10-30 minutes to take effect. Personally I've never had that problem, but it might be worth trying to wait)

Re-upload your site

It might not make any difference, but if possible, remove your site from the server and re-upload it. I recommend using Akeeba Backup for this.

Disable .htaccess

Try to temporary remove or rename your .htaccess file.

Cookie Domain

In your configuration.php file, check if the following variables has any values. If they do, change them to this:

public $cookie_domain = '';
public $cookie_path = '';

Cache problem

It's possible that it has to do with a cache problem, or a caching system not supported by GoDaddy. Check the following lines in your configuration.php file, and change them to the following:

public $cache_handler = 'file';
public $caching = '0';
public $session_handler = 'database';

$live_site variable

Verify your $live_site variable in configuration.php. It should be empty, or read

public $live_site = "http://www.example.com/home";
  • Thanks, johanpw. I tried uploading and restoring again the database and it seems to be working (my bad, sorry!). However, it remains a very serious problem, to which I haven't found a solution yet: the images on the website are not displayed! Please see here: joomla.stackexchange.com/questions/7602/… – Khue Feb 13 '15 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.