2

I'm getting a blank page when attempting to install AutoTweetNG on Joomla 2.5. I've already checked the post_max_size and upload_max_filesize variables in the php.ini, which are set to 20M and 60M respectively. I know that post_max_size should be at least as much as the upload_max_filesize because it takes precedence when uploading, but the filesize of the extension is far below the limit. Error reporting is also on, yet the page doesn't display any errors.

Uploading from the package file: Blank page

Uploading from directory: Blank page

Uploading from URL:

Error alternates between:

Error connecting to the server: SignatureDoesNotMatchThe request signature we calculated does not match the signature you provided. Check your key and signing method.AKIAJJR5V3C52VV5NZFQGET 1423257975 /xtl-repo/autotweetng-free/UNZIPME-autotweetng-free-v7.6.1.ziplulF3Na fitF0he7nYydlNZPYpQ=47 45 54 0a 0a 0a 31 34 32 33 32 35 37 39 37 35 0a 2f 78 74 6c 2d 72 65 70 6f 2f 61 75 74 6f 74 77 65 65 74 6e 67 2d 66 72 65 65 2f 55 4e 5a 49 50 4d 45 2d 61 75 74 6f 74 77 65 65 74 6e 67 2d 66 72 65 65 2d 76 37 2e 36 2e 31 2e 7a 69 70721094E0DA5021BAA/gSDt7RRP8K2NwWGRjeo9gQtXPzihJSt9gFd+w5j0Hsn68oc8rNacuV+aIc72AX
Invalid URL

And:

Unknown Archive type

Been at this for a few days, any help?

EDIT: Forgot to add, I am able to successfully install all other extensions. It's only
this one I'm having trouble with.

  • If it's only this one then would you not deem it better to contact the developer of the extension? – Lodder Feb 6 '15 at 21:22
  • Thousands of other people have installed this extension just fine, so I doubt it's the developer's fault. I've already checked the recommended page on the Akeeba troubleshooting page as well. – Henry A. Feb 6 '15 at 21:32
1

If you try to install with an Url, you have to install with the Url targeting to a component file. It is a common practice to name extensions with UNZIPME-....zip when it includes optional plugins or other assets.

In this case, you have to download, unzip the file and install the main component.

In any case, review the installation instructions: http://www.extly.com/docs/autotweetng_joocial/installation.html , and check if you are running the latest Joomla 2.5.28.

  • I only happened to use the UNZIPME version of the file, I get the same error with the main component zip file. – Henry A. Feb 6 '15 at 21:29
  • You cannot get exactly the same error uploading a component file from your PC. In any case, check the installation instructions: extly.com/docs/autotweetng_joocial/installation.html , and check if you are running the latest Joomla 2.5.28. – Anibal Feb 6 '15 at 23:53
1
  1. Check your php/apache error logs And / Or
  2. Uninstall and reinstall the latest version of Xampp And / Or
  3. Make sure the extension is supported for Joomla version you are installing on And / Or

  4. Unzip the contents of the extension and extract it. Then make sure that your unzipped folder has a valid extension XML file. Re-Zip the contents and try to install the newly zipped file. And / Or

  5. Start a FRESH htdocs folder for your site. Install a latest fresh copy of Joomla and right away before installing anything else, install that extension.

Source: I develop joomla extensions and templates for StarAzure.com

1

I experienced the same issue and was able to resolve it.

I use WAMP and when I updated my core Joomla from 3.4.6 - 3.4.7, I was faced with the same problem.

What I did was simple.

  1. Turn on Error reporting under your system-server setting to Maximum
  2. In my case, I got an error message which says Access level to JInstallerAdapterLibrary::prepareDiscoverInstall() must be public (as in class JInstallerAdapter) in C:\wamp\www\mysite\libraries\cms\installer\adapter\library.php on line 485.
  3. I accessed the specified line and changed the class name from Protected to public.

Protected function prepareDiscoverInstall()
{
    $manifestPath = JPATH_MANIFESTS . '/libraries/' . $this->extension->element . '.xml';
    $this->parent->manifest = $this->parent->isManifest($manifestPath);
    $this->parent->setPath('manifest', $manifestPath);
}

To

public function prepareDiscoverInstall()
{
    $manifestPath = JPATH_MANIFESTS . '/libraries/' . $this->extension->element . '.xml';
    $this->parent->manifest = $this->parent->isManifest($manifestPath);
    $this->parent->setPath('manifest', $manifestPath);
}

I hope this helps someone.

0

Sounds like the script isn't coming back. As far as I know, PHP is only rendering at the end of the script. So, if the script reaches its max execution time, it displays a blank page.

Try to set a higher value to your max_execution_time variable in your php.ini and to install it via the joomla package installer again. Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.