1

When I click a tag that is assigned to at least one article I get the message: The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete (This is when using firefox). When I click on tags that are not assigned to articles, they can be opened.

In another browser the error is : The website at http://website.com/tags/35-tag seems to be unavailable. The precise error was: Too many redirects

I don't really know what's with too many redirects or how to fix my broken tag pages.

Update1:

I checked my tags table, and saw that one of the tags that doesn't work has for its alias the aliases of all the other tags. For example the tag "cool cars" has the alias "tag-a/tag-b/cool-cars/sports/tag-c/...etc". I expected the tag “cool cars” to have the alias “cool-cars”. In the database in the urls field I see this value: {"0":"{\"urla\":\"\"}"}

Update2:

I exported that tag to have it as an example, deleted that tag and the rest still don't work. After I switched off friendly URLs and URL rewriting this is the error I get for the tag TOP, assigned to some articles:

1054 - Unknown column 'top' in 'where clause' SQL=SELECT alias FROM dh5w1_tags WHERE id = 2362-top
2

This is looping behavior, but I can't pinpoint the cause from the information given. What it is implying is that it's trying to link http://website.com/firstaddress to redirect to http://website.com/secondaddress and that http://website.com/secondaddress either links to firstaddress or something different, throwing the whole site into an endless wild goose chase for the ultimate correct page.

Steps to correct:

  • Turn off url rewriting.
  • If the urls behave correctly with SEF urls off, the problem is in the words used.
  • Words could be as simple as using the word "media" as one of your tags, with "media" being a folder already used as a default Joomla core folder name, thus its use in a URL might confuse the rewrite system.
  • If the urls behave incorrectly with SEF urls off, you have a problem with the system itself, but the errors you get with SEF off should be more descriptive (we hope!)
  • Turned off url rewriting and still nothing. As you see link this is my tags page and "1 mai" that isn't assigned to any article can be opened and 13paispe that is assigned to some articles for example, gives that redirect error. – user51649 Feb 4 '15 at 19:17
  • Hello. Apparently don't know why this is happening but checked my tags table, and one of the tags that doesn't work has for alias all the aliases of the other tags( I guess the ones attached to articles). For example the tag "cool cars" doesn't have the alias "cool-cars" but the alias "tag-a/tag-b/cool-cars/sports/tag-c/...etc". And in the urls field has this value: {"0":"{\"urla\":\"\"}"} – user51649 Feb 4 '15 at 21:58
  • I'm sorry it took so long to get back to you...what is an example of a url that doesn't work when SEF urls are turned OFF, and what is the resulting error? – Toni Marie Feb 13 '15 at 18:46
  • I didn't got any help on my issue, maybe because no one could help me or didn't wanted. Sadly, with tears in my eyes, literally, switched back to Wordpress because I needed so badly a functional site. I don't know exacly how the URL's were like but I made back then and made a printscreen with my error. If you see my message, and have any clue about that I'll apreciate it. And I don't really want to solve the issue since I'm not on Joomla right now, but to understant why is it happening. oi60.tinypic.com/1jqnwi.jpg – user51649 Feb 21 '15 at 20:43

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.