1

After recovering joomla site from failed upgrade and from corrupt backup i at least got it to display something but now all my pages by default point to /index.php/en/ and because its pointing to "en" folder all my template images and site images not showing. It automatically fills in when trying to access website. Any idea how to remove /en/ ?

Here is what i tried: disabled language filter -- i get error 500 play around with url rewriting -- i get error 404

My previous setup used to be like this: /index.php?lang=en

  • Was the site multi-lingual before this? It sounds like English is set as the primary but that another language is possible also enabled. That is why the en shows up. – Brian Peat Jan 28 '15 at 1:28
4

There is no need to set non-friendly SEF URLs. I have a multilingual website too and I had your same problem. Do as following: Go to Plugins -> Language Filter and set Yes to: Remove the prefix from default language. Hope it helps :)

0

I figured it out my self. Switching to non friendly sef URLs fixed my problem. You can do this from Global Configuration.

  • 2
    Non-SEF URL'S look horrible though :/ – Lodder Jan 27 '15 at 17:40
  • It is hard to share a page on facebook or others without SEF URL. Because they ignore the address after ? character. – zkanoca Jan 30 '15 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.