If you check this webpage: http://www.benaventegrow.com/ I don't know why, but SP Smart Slider module doesn't load.

It must be a JQuery conflict. I have read about the .noConflict() function, but it's already implemented in the jquery code.

When I disable the Jquery VirtueMart option, it works, but in shop, the prices don't update when I choose another product. If I active it, the slider doesn't work, but the prices do.

What should I do? I need the prices and the slider working.

P.S. In the console, I am receiving this:

Uncaught TypeError: undefined is not a function

 autoplay  : 1,
 interval  : 7000,
 delay     : 0, 
 fullWidth : false

It's marking the delay option (with value 0).

1 Answer 1


Looking through the JS within the <script> tags in the browser console, I can't seem to find anything wrong, however I did notice you have 2 instances of jQuery being imported.

The first one from the K2 extension, and the other one from GoogleApis CDN but as it's external, I don't know where it's being called from. The one coming from Google os an older version so I would suggest trying to remove this one.

It could possibly be being called from the Smart Slider extension, so check the options for it and see if there is anything relating to disabling jQuery.

If push comes to shove, then I would recommend using jQuery Easy, which is a plugin that strips out all instances of jQuery and uses it's own, along with many other features.

Hope this helps

  • I tried removing Google Apis, but It didnt work. Now, I've just downloaded JQuery Easy, but I have completely no idea about how to use it
    – Antonio
    Jan 26, 2015 at 9:19
  • Please read the documentation for it. All that should be done is you enable the plugin and define the version of jQuery that you wish to use
    – Lodder
    Jan 26, 2015 at 9:32
  • OK, I did it. I downloaded Jquery 1.11.2, I put the path of the file. I enabled the plugin, and i disabled Google Apis, and It still doesnt work. I have also tried disabling JQuery VirtueMart. But Slider only works when ALL Jquery files (plugin, virtuemart and google apis) are disabled... It's really annoying. I have no idea what it is. I tried to look for any setting in the Slider about Jquery, but i found nothing... So... what could it be?
    – Antonio
    Jan 26, 2015 at 9:42
  • You don't need to download jQuery, you can import it via CDN which is the preferred method. My guess would be to fiddle around with some of the VirtueMart options and see if anything gets fixed without completely removing it.
    – Lodder
    Jan 26, 2015 at 9:50
  • Those are the options you can enable/disable... I have tried all, I guess gyazo.com/ef6bed680f75b6106576356c5e4a1fa0
    – Antonio
    Jan 26, 2015 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.