0

So the problem is that modules won't show in sub-categories. If you take a look at my site NerdyFuture. You will see a menu bar with Articles, if you hover over it you will see some sub-categories. If you look at for example Software you will see all articles that are set to the categorie Software. I want to remove everthing from it except the navigation and only use a module on the page (Mini Front Page module). I tried to add the module to the page but it doesn't show up and yes it's published and set to a position. How can I fix this?

1

This would be a comment, but i do not have enough reputation to do so .. why would you set this page on category articles, when you just want to show a module? of course all the articles are displayed, because that is your setting right now.

you have several different options to display your module. you could either load the position in a single article and link to this one.

or you could set your template in a way that it displays your module position you have the module in as well as an article. you leave the article empty, and just use it to link to it through menu manager.

1

A module can be published, set to a position as you say, but it also must be allocated to one or more menu items. Double-check the mini-frontpage module settings to ensure you have specified where it is to appear. You may have overlooked this tab completely.

  • I did assign it to a menu item, it still doesn't appear. – Nerd Zilla Jan 25 '15 at 12:27
  • If the module is still not appearing, check that the template style or layout variation you are using per page actually contains the module positions you need. What I mean is; I notice from your URLs that subpages are using: "?layout=blog", meaning that they are using a "Blog" layout rather than the default. If oyu can fix this issue with your particular template I think you'll find your modules will reappear :) – David Jan 26 '15 at 13:52
1
  1. Your main menu is hardcoded inside your template. This is contrary to everything a CMS is meant to be. As a consequence, you can't control where your modules are displayed using menu assignments. Only modules that are set to be displayed on all pages will be visible.

    The correct way to do it is to replace your entire menu <ul> list with this:

    <jdoc:include type="modules" name="position-1" style="none" />
    

    Then create a menu module, and publish it to position-1.

  2. You're modifying the Protostar template. Because this ships with Joomla, it's considered a core hack. You should copy the template and continue working on the copy, because it's only a question of time before all your changes will be lost in a Joomla uprade.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.