1

I try to run the openwebanalytics software locally under wampserver and joomla using the instructions of this video.

I have created the db.

I have insert the owa file under the joomla site.

I type in my browser the path for the file

  http://localhost/openwebanalytics/owa/install.php 

and press the start button.

In the next step I get this error but I can insert the data for the db.

I press the button for the next step and I get only warnings.

What could be possible wrong with the process?

2

First of all, are you sure you need to install OWA on localhost? I don't see any important reasons for this, as you'll still need to have it on a web server in order to track anything.

Your error states that preg_replace using the /e modifier is deprecated. This is deprecated as of PHP 5.5, thus I'm guessing you're using Wampserver with PHP 5.5. According to the OWA Technical Requirements, the software requires PHP 5.2.x or later, but it looks like PHP 5.5 is not fully supported yet.

I suggest you install OWA on a webserver running PHP 5.4.x until PHP 5.5 is fully supported. If you have to use it on your localhost, you can find older versions of Wampserver at SourceForge.

  • Thank you for your answer. I tried this but I have a problem with joomla installation. It takes to much time to install the new site even if I used an older version of joomla. – foc Jan 12 '15 at 19:20
  • You don't need an older version of Joomla, Joomla is independent of your PHP version. But I agree that reinstalling wampserver also takes time. Any particular reason you want to run OWA on localhost? – johanpw Jan 12 '15 at 22:02
  • Yes it is for teaching / learning purpose. – foc Jan 13 '15 at 10:22
  • @foc Then you might have to switch to Wampserver 2.4, this version comes with PHP 5.4. – johanpw Jan 13 '15 at 11:48
  • Yes I tried this solution but I think that I have a problem with the installation of Joomla. Everything works perfect until the 3rd step of Joomla installation / configuration. It sticks in the 3rd step "creating database tables". It shows that it is in process but for about an hour it is in the same situation. I checked the db of joomla and it has some tables. I don't encounter this problem with the newest version of wamp. – foc Jan 13 '15 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.