2

I've searched around a bit but didn't find a guide yet. Something with a checklist would be great.

3

2 Answers 2

6

While not an as extensive guide as Adapting a Joomla 1.5 extension to Joomla 2.5 these two backwards compatibility articles on Joomla Doc's helped us.

Update

Nick also found this non-Joomla Doc's article:

1
  • Thanks @cppl. If others find helpful links they will post here. Google indexes stack exchange pretty well so most people also looking for the answer to my question will find this page. Commented May 7, 2014 at 18:34
1

There is a doc page explaining the potential backward compatibility issues between 2.5 and 3.x. http://docs.joomla.org/Potential_backward_compatibility_issues_in_Joomla_3_and_Joomla_Platform_12.2

Make sure you don't use any of the deprecated and removed methods found in there and the extension should work in J3.x.

2
  • Ummm the questions about updating an extension, I sort of read that to mean something like the Adapting a Joomla 1.5 extension to Joomla 2.5 article…
    – Craig
    Commented May 6, 2014 at 8:51
  • Ah sorry, misread the question then. Changed my answer now.
    – Bakual
    Commented May 6, 2014 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.