3

I have created a Template, just as one should and everything works, just as it should, BUT when I access the template through the template manager (not the template style) I get this warning:

Extension record not found in database

Image of error

Anybody any Idea how to get rid of it, or what the cause could be?

Thanks in Ahead!

2

Sounds to me like you might have copied a template, and not installed it - that worked in earlier versions of Joomla, but not so in later versions. Check this to be sure you covered all the bases.

In short, the installation puts the record in the extensions database, so you either have not installed the template, or if you did, you may have left old values from the template you copied that should have been changed. So - the extensions table may already have had a record that matched what you tried to install, or some other similar reason that the new extension record could not be added.

  • Thanks so far! I had a look at the extension table! The template appears in there. As you said, I copied an existing template, changed the whole templateDetails, the »prefix« in the Language Files and installed it via »discover«… »may have left old values«, which could that be? – philipp Jan 6 '15 at 19:46
  • Could be a million things - I'd scan for any occurrence of the original template name in all the files that were copied, and the same in the extensions table record - something was missed as it appears to be looking for a file that isn't there. Also file NAMES, not necessarily just strings within files. – GDP Jan 6 '15 at 20:45
  • Maybe also try removing your template completely (all references from the database too) and reinstalling it – Lodder Jan 7 '15 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.