1

So I tried to remove the latest news module. But it just kept on displaying on my home-page. How can i make it go away? I tried to clear cache, that did not work, also if I change the Menu Item Type of the home-page from featured articles to something else, the latest news module disappears then. How can I make it disappear without changing the Menu Item Type?

I tried to unpublished it but it wont go away, also there is no code for the module in the index.php.

I just noticed that my css does not load properly. It will probably look something like this, everything in the red box needs to be removed.

enter image description here

  • Share link and I will guide you through. – Salil Momin Dec 27 '14 at 11:23
  • Am i right in assuming you have disabled it? And also disabled the correct module? – Lodder Dec 27 '14 at 11:30
  • Yes, i'm 100% sure I did that – Nerd Zilla Dec 27 '14 at 11:42
  • @SalilMomin nerdyfuture.byethost24.com. link to my website the pictures next to the top news should be removed – Nerd Zilla Dec 27 '14 at 12:25
  • Ok what I would recommend you do as I assume this is a development site, is firstly disable ALL modules in the Module Manager. Once done, report back with the results – Lodder Dec 27 '14 at 17:20
1

You might be disabling the wrong module, or maybe there's a copy somewhere with a different name.

The best way to find and disable the correct module is to login to your site on the front-end. Go to http://nerdyfuture.byethost24.com/?option=com_users&view=login and login with your superadmin user. Then return to your homepage, and when hovering over your modules you should see an icon similar to this:

Module edit icon

Hover over the icon to see some details about the module (Name and position), and click it to edit it in the back-end. Now you can disable it, and once you click Save & Close it should be gone.

Update
It's possible that the news section is from a module called Mini-frontpage (from what I see in your source code). Make sure you've located and disabled all instances of this module. You can filter the module list by module type in the Joomla module manager like this:

enter image description here

Update 2
Those elements you want to remove are not modules, they are your featured/blog articles loaded in the component area. Basically you have to find a way to hide the component (loaded with <jdoc:include type="component" /> in your template). Some templates has a setting for this, if not you have to create an if-else statement using PHP to determine if the component should be loaded or not. Here's an article on how to detect if the user is viewing the frontpage.

You can try to replace <jdoc:include type="component" /> with the following code in your index.php file:

<?php
$app = JFactory::getApplication();
$menu = $app->getMenu();
if ($menu->getActive() != $menu->getDefault()) {
    echo '<jdoc:include type="component" />';
}
?>

This should load the main component area on all pages except your homepage.

  • Thanks, Alright I tried that, the problem is that there is no editing icon for the module itself, there are icons for the articles. So if i try to edit something, it will edit the article not the module. – Nerd Zilla Dec 27 '14 at 14:52
  • @NerdZilla I have updated my answer with another option, but after looking closer at your website I'm a little confused as to what part you want to remove... – johanpw Dec 27 '14 at 15:15
  • @Lodder Well, it did not go away, but I found something very strange, what i did is just unpublished every module I had. After that my web-page was completely empty, it also removed the latest news. But if I add a module, for example the carousel, the latest news comes back in the left upper corner.(The module is not made by the Mini Frontpage, it is just a standard joomla latest article module) – Nerd Zilla Dec 27 '14 at 18:51
  • I tried to put the code you gave my on a lot of different places. But it is still showing. Could this maybe be a wrong option in the configuration ? Thank you very much for all the effort! – Nerd Zilla Dec 27 '14 at 19:39
  • Yes, I will send you an a email – Nerd Zilla Dec 27 '14 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.