0

Joomla System Information

Why isn't my PHP version updated, although I updated to the latest Joomla 3.3.6?

7

As others pointed out, Joomla does not install PHP. Upgrading or installing Joomla will not change your PHP version. PHP is usually installed and updated by your hosting company (or by yourself if you manager your own server).

Joomla 3.3.6 requires PHP 5.3.10 or above (5.4 + recommended). According to your screenshot you're using PHP 5.4.32, so you should be fine. If you want to use a more recent version, you should contact your hosting company. You might be able to switch to PHP 5.5 by changing a setting in your control panel, or by adding a single line of code to your .htaccess file.

The process depends on your hosting company, but look for "PHP Version Manager" or "PHP Configuration" in your cPanel:

PHP Configuration

Then select your desired PHP version. Make sure all your Joomla extensions are compatible with the version you choose. Some hosts allow you to choose to always use the most recent PHP version, but this might not be a good idea as your site might break when PHP is updated.

PHP Version configuration

6

Joomla is not shipped with PHP, therefore if you update Joomla, it will not update your PHP version.

PHP is a server side language and must be upgraded my either yourself or your host. Only some hosts (if you're on a shared hosting package) allow you to select a different PHP version. The reason being is that on some shared hosting packages, the same PHP package is used for all users on the same server.

Check your options on your hosting admin control panel, else you will need to contact your hosting provider and ask them to upgrade it for you

2

Make sure what is the php version installed at your server.

And if you have installed it still changes are not getting reflected then restart your server.

Joomla does not install any other resources like php.

You need to install it.

  • Sorry, could you tell me how to install the PHP lastest version at my server, please ? – Vanh Ltk Dec 26 '14 at 7:30
  • and how to use Akeeba backup in joomla 2.5 ? – Vanh Ltk Dec 26 '14 at 7:39
  • for php upgrade, you can refer this link liquidweb.com/kb/… this can also be done via shell commands – Nick Dec 26 '14 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.