1

I am using Joomla 3.3.6 site on VPS, yesterday my hosting provider upgraded from PHP 5.3.29 to PHP 5.4 and now i am getting following errors on my live site:

We asked them to revert back to php 5.3.29 but still having same issue:

Strict Standards: Only variables should be assigned by reference in /home/livemedi/public_html/modules/mod_media_media/helper.php on line 29

Strict Standards: Only variables should be assigned by reference in /home/livemedi/public_html/modules/mod_media_media/helper.php on line 68

Strict Standards: Declaration of hwdMediaShareModelCategories::populateState() should be compatible with JModelList::populateState($ordering = NULL, $direction = NULL) in /home/livemedi/public_html/components/com_hwdmediashare/models/categories.php on line 214

Strict Standards: Non-static method hwdMediaShareCategory::get() should not be called statically, assuming $this from incompatible context in /home/livemedi/public_html/components/com_hwdmediashare/models/media.php on line 85

I would appreciate if someone can help me in this regard.

4

Quick solution: Turn off error messages. Just go to "Global Configuration" in your backend, switch to the server tab and set the error reporting to none.

Better solution: It's better to fix the issues than just to hide them. These are some small issues in 2 extensions that you use (mod_media_media and com_hwdmediashare). You could look for updates for these extensions (prefered option) or fix the issues by yourself. For the latter you would need some PHP knowledge and your changes to the files might be overwritten with the next update of these extensions.

  • E STrict mod was causing this issue. Issue has been resolved :) – Naeem Dec 25 '14 at 13:13
1

Update Joomla and third party extensions to the latest versions as this may have been fixed.

If the code can't easily be updated to fix the warning messages, there are a few ways you can can suppress the messages from being displayed, depending on your hosting environment.

Try (in the following order):

1. Global Configuration Update

Set System -> Global Configuration -> Server -> Error Reporting to "None"

2. php.ini File

Add the following lines to the start of the php.ini file in the public_html folder (or similar root folder) of your web hosting account (create the file if it doesn't exist):

display_errors = Off
error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT

3. .htaccess File

Add the following lines to the start of the .htaccess file in the public_html folder (or similar root folder) of your web hosting account (create the file if it doesn't exist):

php_value display_errors 0
php_value error_reporting 22527

Reference:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.