3

I recently moved my Joomla 3.3.6 site on WHM/VPS from shared hosting, and now facing too many problems: My Joomla back-end is very slow and now I am getting following error in back-end:

Fatal error: Maximum execution time of 30 seconds exceeded in /home/mydirector/public_html/libraries/phputf8/mbstring/core.php on line 121

mbstring is enabled in VPS/WHM.

What should i do? I cant work in back-end properly.

Php: 5.3.29 MySQL version 5.1.68-cll Apache version 2.2.29

I would appreciate if someone can assist in this regard, because I contacted with hosting provider and they told me its not our problem. And i believe this is from VPS side because i never ever had issue on shared hosting but on VPS

  • Since you're on a VPS, you can likely up the Max execution time to something like 60 or 120 seconds. That's not a very good long-term solution, since you have to wait that time for each page load. I would up the max execution time and then figure out what extension is using that call and disable it. Most times the VPS is actually less powerful than the shared hosting, the resources are just dedicated to you. – David Fritsch Dec 21 '14 at 1:53
2

As David said in the comment, you'll need to increase your execution time (see this question/answer). Once done, you should be able to run the Administrator and turn on Joomla Debugging. With that enabled, you pages will show all sorts of diagnostic information, most particularly how long pages took to load, and where it's happening.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.