2

Running ubuntu 14.04 Joomla 2.5.27 locally (2.5.28 remotely - not relevant to my question as far as I'm aware.)

I am having trouble configuring my site to run locally. I have the site installed on my localhost server and can browse it fine.

When I try to update to version 2.5.28 from 2.5.27 before finally looking to update to 3.5 I receive the following error message:-

"There was an error uploading this file to the server."

I have checked out question people have asked before here on stackexchange and other sites and tried various things.

1)Like changing folder permission. Currently set to 755 I believe. 2)Changing the path of the logs and tmp files to :

public $log_path = '/var/www/log'; public $tmp_path = '/var/www/tmp';

3)setting the password for my local msql database - of course,else the site wouldn't work. Root password.

4)Changed the size of the file allow in ini.php

https://stackoverflow.com/questions/21411896/error-uploading-big-extensions-to-joomla-on-a-localhost

I'm a bit at a loss as to what I'm doing wrong.

  • Your $tmp_path is incorrect. It needs to be something like C:/wamp/www/tmp or something similar starting with your local drive path – Lodder Dec 20 '14 at 17:18
  • @Lodder ... not if it is run on ubuntu I guess... – elk Dec 20 '14 at 17:30
  • BUT did you install Joomla directly in www or is it a subdirectory? Then the subdirectory folder might be missing in your paths. Also, did you try using 775 for permissions? – elk Dec 20 '14 at 17:33
1

In the BE, navigate to

System Information > Directory Permissions

The status should be green for all folders / files, especially the tmp directory.

enter image description here

If you see this as "unwritable" you need to change this.

There is some good documentation about this in Installing Joomla on Debian Linux. See the section with Set ownerships and permissions.

  • thanks - that has brilliantly sorted out my file permissions and made everything writable as I've chosen to do. If I make all folders in /var/www/html writable does that make my site less secure when I upload remotely? I can now upload files, or at least smaller ones. A 2.8MB one that was a patch won't upload. I guess this may be related to a setting on ini.php? I will research further. – user4702831 Dec 20 '14 at 20:48
  • It is hard to answer in a sentence. You will find some similar questions here as well as documentation on docs.joomla.org on how to set the correct file permissions. – Valentin Despa Dec 20 '14 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.