2

I have just experienced something weird with the language filter in combination with the Google crawler.

If I switch on browser detection, Joomla returns a 404 (I assume, because no "ALL language" article is present), as the crawler has no language preference. I thought, the default language would be used in such a case.

Haven't found a solution yet, to get the same behaviour as when access is made by a visitor through a browser.

How do you handle this?

  • I can't answer your question, but this link has come in handy viewing a link in the same way that the search engine bots do: aw-snap.info/file-viewer – GDP Dec 19 '14 at 19:46
2

Have you set up your site to be multilingual - i.e. separate menu for each language with corresponding and linked articles? What settings do you have on the multilingual side of things - e.g. the language filter plugin?

I'm not sure if this article helps: https://support.google.com/webmasters/answer/182192?hl=en#1

If your site is properly set up to use multilingual and is working, I wouldn't worry too much about what happens when you're trying to crawl as Google, unless you're seeing errors in Webmaster Tools?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.