1

I'm working on a Joomla site and for some reason my site quit knowing it was logged in on the default page. Other pages still know that I'm logged in. Even the default page knows I'm logged in if I include index.php in the url. For example, http://mysite/proj/index.php#home1 works but http://mysite/proj/#home1 does not. I know this was working a few days ago but it has stopped working for some reason and I have no idea why. I've tried restoring to a point a few days ago and that has not worked but since I have no idea why this is happening it is difficult to even know how far back I need to go or weather this is even due to something I've change with the file system.

There is really not much to go on. I can tell you that neither the PHP log or the Joomla logs are reporting anything. I have only one cookie set for the domain and it is for the root and appears to only contain a session ID type hash string.

Update

After restoring a from the nightly backup made last night my site is suddenly working properly again. Unfortunately, as far as I can tell this is the exact same setup I was using this morning which wasn't working. So now the nature of this question has changed slightly. Now I'm just looking for some sort of explanation as to how this could happen so that I can prevent it from happening again in the future.

BTW, while this was broken I had tried loading the page from IE and Chrome on several machines on several networks (internal, external and my home). All produced the same error so I doubt this is a client issue.

Also, when I viewed the source the jmoddiv were all empty so this is probably not a style issue either (IOW, they weren't hidden).

Update 2

I forgot to mention that I'm on Windows (I know, I don't like it either but despite my objections this isn't going to change) using IIS5. So I'm not using mod_rewrite or .htaccess files.

migrated from webmasters.stackexchange.com Dec 15 '14 at 15:40

This question came from our site for pro webmasters.

2

This sounds like it could have been an issue with .htaccess and/or URL Rewriting (in System -> Global Configuration).

Make sure URL Rewriting is set to "Yes", that you have renamed htaccess.txt to .htaccess, and that the following lines are set correctly in .htaccess:

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

(Leave the code above activated (not commented out) unless you're getting 500 Server error messages)

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

Try uncommenting RewriteBase /. Don't make any other changes unless you have installed Joomla in a subdirectory of your domain. If that's the case, add your subdirectory after the /.

If you still have a copy of the website causing the error, try comparing the .htaccess file with the one that's working now.

  • Thanks for the tips. I am not using mod_rewrite or even .htaccess files. Furthermore, I'm stuck on IIS5 which doesn't support either even if I was. – krowe2 Dec 15 '14 at 18:27
  • I'm not familiar with IIS, but you can enable mod_rewrite on IIS by renaming web.config.txt to web.config. It's a long shot, but this file might be causing trouble (based on what you say about the site working if you add index.php to your URL. Read more about this here. – johanpw Dec 15 '14 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.