I have a multilingual joomla site setup and would like to use a different domain for each language.

So instead of "englishsite.com/en/" and "englishsite.com/fr/", I would get "englishsite.com/" and "frenchsite.com/". And the domains and language would switch with the Joomla language switcher module.

Could this be done with Chameleon component, or .htaccess redirects? Should I use something like Falang for translations instead of Joomla Core setup?

1 Answer 1


(I'm not familiar with Chameleon, but from what I see after a quick look, you could be able to make it work.)

However, the Joomla Documentation has an article regarding a similar example, with a couple of different approaches. You should take a look at it.

The following should work, although I haven't tested it (based on option #3 from the link above):

Basically, you set up your cPanel with a main domain (englishsite.com) and an addon domain (frenchsite.com). Then you could tweak the following code to fit your needs, and add it to your templates index.php AT THE VERY BEGINNING:

$domain = $_SERVER["SERVER_NAME"];
$requri = $_SERVER['REQUEST_URI'];
if (($domain == "www.englishsite.com" && $requri == "/" || 
   $domain == "englishsite.com"))  { 
   header("Status: 301 Moved Permanently");
   header("Location: http://www.englishsite.com/en"); 
if (($domain == "www.frenchsite.com" && $requri == "/" || 
   $domain == "frenchsite.com"))  { 
   header("Status: 301 Moved Permanently");
   header("Location: http://www.frenchsite.com/fr"); 

Make sure you enable SEF urls for your site (Global Configuration -> SEO settings).

Finally, go to the plugin manager and locate the plugin System - Language Filter. In the plugin settings, set "Remove URL Language Code" to Yes.

Language Filter plugin

  • I do not have cPanel as my hosting provider does not offer it. Both domains are directed to the same folder. It was working for a few minutes and then stopped working... I think I'm having difficulties with the homepage as well, on the englishsite.com when I go back to the homepage it sends me back to the frenchsite.com. I've gotten redirect error pages trying to make it work.
    – oturpin
    Nov 21, 2014 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.