1

Function getLanguage() works on .de but not on .com domain?

Did I forgot sth. right in the code?

The Code

Directories:

enter image description here

6
  • How does the .com domain compare to the .de one? I assume they are not 2 different site. Is 1 pointing to the other?
    – Lodder
    Nov 17 '14 at 16:32
  • I'm not realy sure, but I guess .de points to .com. Nov 17 '14 at 16:35
  • Are you 100% sure that .de points to .com and they are not 2 different websites?
    – Lodder
    Nov 17 '14 at 16:41
  • No, I'm not. But I am working on .de and everything (except the getLanguage()-function) works. Switching language has no effect. echo $tag; : output de-DE, even after selecting english (on .com domain). Nov 18 '14 at 9:43
  • This is a fundamental bit of information that is required. If the domains are 2 completely different Joomla sites then of course the code will not work. The code you're using will get the language from the Joomla installation that you have specfied, thus if they are 2 different installations, then you will also need to import the Joomla API from the .com site
    – Lodder
    Nov 18 '14 at 9:48
1

I'm going to write this as an answer to I can go into further detail and explain things clearly :)

Ok so you have 2 websites:

  • www.example.de
  • www.example.com

It appears that the .de domain is your primary website. So, then you go to the .com website, it will either redirect to the .de website or simply display the website.

If you navigate to www.example.com/administrator, again, it should either redirect or not. If it doesn't then they are most likely 2 different websites.

So far you should be able to tell us what happens when you view the .com domain.

Assuming there is no redirect, go your your File Manager (hosting cpanel or FTP) and you will see the files/folders for your Joomla site. You may also see a sub-folder with a separate Joomla installation side it. If you do then you will also need to import the API from this sub-folder too.

4
  • 1. I can't get into www.example.com/administrator - I get 404 not found. 2. I can't find a files/folders within FTP. (found web\plugins\editors\jckeditor\install\models\folders.php) Nov 18 '14 at 10:38
  • files/folders isn't a directory. I simply meant your Joomla files and folders. When I said www.example.com/administrator, I didn't mean this exact domain. You obviously need to change example to whatever your domain is.
    – Lodder
    Nov 18 '14 at 10:45
  • It is obvious what you mean with example :) But I didn't get which folder I have to find now. Nov 18 '14 at 12:44
  • The folder could be anything. Like I said, It's not certain that you will have a sub-folder with another installation inside but possible. Can you take a screenshot of the root of your Joomla installation please so I can see
    – Lodder
    Nov 18 '14 at 12:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.