2

I'm trying to link the news update preview off a roksproket mosaic to the full article on a separate page. I created a category called news and made a new article where I wrote what I wanted to write for the news update. Then I configured the roksproket mosaic module to feed from the news category and the article shows up in the mosaic. The problem is when I click on the mosaic link, the article text displays on the home page at the bottom. Check it out at http://jchsrobotics.com

4

You're actually linking to the article just fine. But, because there's no menu item to change your module assignments, you're linking to your article page with the mosaic module still published to the page. You can tell you've navigated to a new page by looking in the address bar.

Joomla's module assignments are based off menu itemids. Without an itemid assigned to that article set, Joomla assumes you want to inherit the module makeup from the page you're linking off.

You'd want to make a hidden (or visible) menu item to at least the category if not the article, in order to make sure the module assignments are specific only to the front page and not to your article.

  • Beat me for the same answer by seconds, +1 :P – Jordan Ramstad Nov 5 '14 at 16:03
  • Sorry, I'm a bit confused on how to properly create a menu and link it with the article. I created a menu with the menu type of "hidden" (don't even know if that works?). After creating the menu im stuck. – Akash Hegde Nov 5 '14 at 16:19
  • Create a menu item that links to that article or the category (there are many options). The main thing is you want to link to the content component more or less. After that the link should be directed to that menu item. Not sure exactly how to do that with roksproket but there is probably info available. – Jordan Ramstad Nov 5 '14 at 16:21
  • 1
    Just as an aside, a hidden menu is just any menu outside your main menu that doesn't have a module displaying it. It's a common Joomla fix for things like this. If you don't publish that menu as a module, it's "hidden". – Toni Marie Nov 5 '14 at 16:27
0

An alternative to this is to use NoNumber's Advanced Module Manager and set it to "Home Page." that fixes the issue completely without having to make a bunch of hidden menu items (if you need to do this for other stuff).

http://www.nonumber.nl/extensions/advancedmodulemanager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.