2

I have followed the instructions given in following forum post and also googled for how to upgrade joomla 2.5 to 3.0

http://forum.joomla.org/viewtopic.php?f=710&t=793171

After that my process was as follows

  • Check availability of new version
  • Update all extensions (Modules, Components and Plug-ins)
  • Delete all extensions that are not compatible with Joomla 3(There are few extensions that we don’t use)
  • Update Joomla 2.5 to 3.0
  • Create templates
  • Create Template, library and MVC Overrides
  • Check all functionalities

I have done four steps successfully. But after upgrading to joomla 3, it works well. Unfortunately I couldn't log into the system after signing out from admin area.

Is there anyone who had such experience earlier?

==============Update===============

I have installed Joomla! 3.3.6 and compared data in login task by printing credentials and result data of login function as below.

    public function login()
{
    // Check for request forgeries.
    JSession::checkToken('request') or jexit(JText::_('JINVALID_TOKEN'));

    $app = JFactory::getApplication();
   echo "<pre>";
    $model = $this->getModel('login');
    $credentials = $model->getState('credentials');
    $return = $model->getState('return');
print_r($credentials);
        $result = $app->login($credentials, array('action' => 'core.login.admin'));
print_r($result);


    if (!($result instanceof Exception))
    {
                var_dump($result);
                die('okk');
        $app->redirect($return);
    }

    parent::display();
}

All data were printed as we enter and result is 1.

    Array
(
    [username] => admin
    [password] => entered_password
    [secretkey] => 
)

1bool(true)
okk

But after redirecting following things happens.

New installation - redirect correctly to back end

Upgraded installation - redirect to login again without messages

Any idea on this?

Thanks.

  • What PHP version are you using (exact version)? – Lodder Oct 27 '14 at 12:02
  • PHP Version 5.4.4 – cha Oct 27 '14 at 12:03
  • Are you using any plugin like securlite ? I experienced same situations after upgrade. – Jobin Jose Oct 28 '14 at 2:44
  • No.I'm not using such a plugin. I have been assigned to another project. Therefore I was unable to check this again. Lets start again. – cha Nov 11 '14 at 6:39
  • Unfortunately plg_user_joomla plugin has been disabled for some reason. Now I can log to system. Thanks everyone who has given solutions to resolve this problem. – cha Nov 14 '14 at 7:40
4

There was a similar question a couple of months ago, and the user ended up starting over with a fresh installation of Joomla.

However, this might not be an option depending on how much work you've put into the site.

Although it's hard to give a definite solution, here's a couple of things you can try:

  • If you're using .htaccess, try renaming it temporarily. Remember that any .htaccess in parent directories will also affect subdirectories (this is important if you updated Joomla in a sub-directory).
  • Check if your /administrator/ directory contains an .htaccess file as well. If it does, please rename it.
  • Make sure the plugin plg_user_joomla is enabled (open your database using phpMyAdmin or similar, and look for it in the #_extensions table, the enabled field should have a value of 1
  • Disable SEF and Rewrite rules in configuration.pnp in your Joomla root folder:

    public $sef = '0';
    public $sef_rewrite = '0';
    
  • Verify if you can log in on the front-end by going to this url: http://yoursite.com/index.php?option=com_users&view=login

  • Set Joomla error reporting to "Maximum" by setting this value in configuration.php:

    public $error_reporting = '6143';
    
  • Download the latest FULL installation of Joomla, and unzip it to your Joomla directory, replacing any existing file (I assume you haven't done any core hacks?).
  • Although it looks like your admin password is correct, try some of these solutions to reset your admin password or create a new user.

Maybe this helps you solve the problem, or points you in the right direction.

  • I have seen a similar issue caused by a redirect conflict. For details, see: joomla.stackexchange.com/a/4769/120 – Neil Robertson Oct 30 '14 at 8:09
  • 1
    OMG. I have checked plg_user_joomla plugin. I has been disabled for some reason. Thanks for the clue that you have provided. – cha Nov 14 '14 at 7:38
2

Go to PHPmyAdmin and open the #__users table. Find the row for your username and in the password column, change the value to:

$2y$10$URiAMY7fBnA75xlGoUmW0uuJ.SegjlM5YnFSPuO.hI9XHzPYxRoPO

This hash = changeme

Now go your the Joomla backend, enter your username and enter changeme for the password.

You can then reset your password back to whatever it was before.

Hope this helps

  • I have tried this. But it wasn't worked. And also I tried this several times before. But no luck. I used md5 earlier.Did you? – cha Oct 27 '14 at 12:12
  • @cha - I've updated the hash and password. Please copy and paste the exact hash I have provided you with. The password should be secret – Lodder Oct 27 '14 at 12:18
  • I have tried it again with your updated hash. But no luck. – cha Oct 27 '14 at 12:28
  • Hmm, and you're using Joomla 3.0 or 3.3? – Lodder Oct 27 '14 at 12:31
  • I have updated today to latest version. I think it's 3.3.6 – cha Oct 27 '14 at 12:33
2

A few additional troubleshooting ideas that may help on this issue, sometimes combined with steps described in the other answers.

  • Clear - Refresh browser cache, cookies, or try with a different browser.
  • Truncate the sessions table from the database.
  • Check if front-end login is still working. Disable SEF urls and use the /index.php?&option=com_users in order to reach the login screen. If you can't login from the front-end, then it's a big chance that something is wrong with the database. It can be that the required authorization/user plugins are disabled, or possibly, another extension that deals with registrations/access/login - so check your database for this kind of extension and disable/enable accordingly.

In many cases a common cause of this issue can be a corrupted assets table. Unfortunately there is no easy fix for this, and it might be better if you could re-update the database from Joomla 2.5 again.

But before you run the upgrade to Joomla 3 again, you might have better luck if you could review any assets issues in J25. Especially if the website was previously updated from J1.5, there is a big chance that the assets table might be messy enough. The component ACL manager component (paid) is a very useful tool that deals with this.

Then run the upgrade to J3. For quicker results, you might want to disable 3rd party extensions so you will only have to deal with the core. When in Joomla 3, go in the extensions manager and check the database tab for any issues. Check if login is working. If yes, you could just start trying copying tables from the newly J3 updated database to your previous one. Try with the following tables first (by testing one by one if it fixes the issue):

  • users
  • usergroup
  • user_usergroup_map
  • assets
  • extensions

Another way you could try import data from J25, is by using the SP_Transfer extension (paid) on a fresh joomla 3 install. This tool is installed on Joomla3 and allows you to transfer data from 2.5. You can select specific tables or records to import. After you do so in J3, you can try again if the login works and if yes, you can copy the above mentioned tables to your upgraded J3 site.

  • Remember to come back and report how you managed to solve this finally, or present any relevant information about the cause of the issue. It seems that this is an issue that many others might encounter, so it will good to gather solutions and causes in here. – FFrewin Oct 29 '14 at 14:19
  • I have updated my latest finding the question. Can you please check. – cha Nov 14 '14 at 6:59
  • I have done your steps and no luck. Removed browser cache, truncated session table and checked user login but it also works as admin. No messages shows when enter correct user name and password. I installed one plugin to enable email as username earlier. But I uninstalled it before upgrade the system. – cha Nov 14 '14 at 7:08
0

Try this: Make a fresh clean install of Joomla 3.

Upgrade the J25 site to J3.

Open PHPmyAdmin.

Start copying db tables from the upgraded J3 to the fresh J3, in steps and by groups, but keep backups of the original J3 fresh tables, so you can easily restore them if needed.

Copy Assets, Extensions, and all Users related, one by one. Every time you copy a table, keep checking if you are able to login. Keep going, till you copy all tables, in order to see if this is caused by anything in your database.

  • Unfortunately plg_user_joomla plugin has been disabled for some reason. Now I can log to system. Thanks FFrewin for all given solutions to resolve this problem. There are lot of solutions in this question to solve this kind of issue. It will help others also. – cha Nov 14 '14 at 10:52
  • 1
    After your last update, I was almost certain that this could be the issue. I think johanwp had already mentioned this in his answer though, and since you said you tried everything, I wanted to walk you through the troubleshooting process, in order to spot exactly when the issue would appear (if in the db), following the table by table process above. Finally, it proved to this simple issue - disabled user plugin. I am glad you figured it out. – FFrewin Nov 14 '14 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.