6

I've created a new Joomla site and trying to post a new article that contains SQL code. When ever I enter the text Declare @allowance decimal(18,2) and save the article I get the following error.

Forbidden
You do not have permission to access this document.

However, I can post the text Declar @allowance decimal(18,2) or just Declare or variations of it. it just throws this error on certain keyword combinations.

I've disabled Joomla's text filtering and also disabled the WYSIWYG editors. And I'm posting the article as a Super User. I can't see mod_security in the list of loaded modules on my host. So I assume this is not the cause of it.

Have you come across this error before? Any pointers please?

Thanks

  • Are you using Akeeba Admin Tools or have you enhanced the security of your site with some additional .htaccess rules? – Seth Warburton May 1 '14 at 8:38
  • I have no .htaccess on the Joomla site. When I tried to add SecFilterEngine Off and SecFilterScanPOST Off to a new .htaccess file the site falls over with an internal error. Not using Akeeba Admin Tools. – Sivakanesh May 1 '14 at 9:18
4

Is it an error shown by the server or by Joomla? Because I would indeed suspect some server security filter here. Be it mod_security or whatever your hoster came up with.

  • I think it is a server error as there are no indications of it in the Joomla error log. And the footer of the error message says "Web Server at testsite.com". Just not sure how to figure out the cause of it. – Sivakanesh Apr 30 '14 at 14:38
  • It's better to ask on another SE site then. Like stackoverflow.com – Bakual Apr 30 '14 at 16:11
  • The hosting company has just confirmed that it is because of mod_security, but I was not able to list it. They can disable it if I wanted. Do you think it is a good idea? – Sivakanesh May 1 '14 at 13:52
  • My hoster had some funny rules in mod_security and I requested to turn it off. Had no problems since then. – Bakual May 1 '14 at 19:53
  • 1
    "You do not have permission to access this document." is definitely not found in Joomla anywhere, so the message has to be from the server. This seems like the right angle! – David Fritsch May 3 '14 at 3:58
0

Your probably hitting the Joomla content filters in the configuration. Try disabling text filters.

http://docs.joomla.org/Entering_raw_HTML_in_editors

  • While linking to documentation is the right thing to do, consider adding a few words to your answer so that it includes the basic steps that need to be followed. – Valentin Despa May 1 '14 at 18:26
  • Tried that. It's not from Joomla. It's the mod_security. – Sivakanesh May 1 '14 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.