3

Had a site up and running fine last night and today when I try to log in to the admin section it just send me straight back to the administrator log in page, no errors about incorrect username or anything, its like its stuck in a loop.

I've done my share of googling and have tried

  • ensuring all user and authentication plugins are enabled
  • deleting all sessions from the sessions table
  • making sure there is nothing in the cookies fields in the configuration.php
  • setting the sessions handler in the configuration.php to none

Front end of the site seems to work fine although I have noticed one anomaly, on an internal page images aren't showing, it failing to load the url. On the homepage however they load fine....

  • Are cookies (and JavaScript) enabled in your browser? Have you tried accessing your site in "private browsing" mode to ensure that any local cookies/cache are not interfering? Tried a different browser? – MrWhite Apr 30 '14 at 14:37
  • This could be a session error. Have you got a chance to access the database and empty the sessions? – jackJoe Apr 30 '14 at 14:38
  • 1
    Have you checked error.log for any errors? – Dmitry Rekun Apr 30 '14 at 17:34
  • Have you changed something on you .htaccess file? – Pep Lainez Apr 30 '14 at 19:43
  • 1
    @cppl I'll post you the address via email, rather not put it out in the public domain. PS Gday from Albury – rowanwins May 1 '14 at 6:17
2

I think you have accidentally unpublished the Joomla User plugin. Using phpMyAdmin, or whatever tool your host provides for you to access your database, look in the xxxxx_extensions table for plg_user_joomla. The "enabled" field should have a value of 1. If it's 0 or something else change it to 1 and try logging in again.

  • Hi John, yep I'd already checked that and no joy sorry. – rowanwins May 1 '14 at 4:08
  • Hi John! Next time please read more carefully the question asked. Author already wrote in it that he have checked the plugins. Thank you. – Dmitry Rekun May 1 '14 at 5:37
  • He did, but in an abstract meaningless way. When describing a problematic situation you need to provide specific information. Stating enabling all user and authentication plugins doesn't mean the plg_user_joomla is enabled, how to know it is available. Could have been removed! – sovainfo May 1 '14 at 15:36
1

After trying all the options I found across the various forums and blogs I ended up setting up a fresh install of joomla 2.5 and basically reinstalling all my extensions and then copying what I could from the old database (eg articles, menus, module settings etc).

To get the site back up and running to a reasonable state using this method took a couple of hours but that was less time than I spent googling and tring random solutions which didn't work!

Thanks for all your suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.