4

I have here Joomla Version: 2.5.24. Currently, Joomla released its newest version. Is it OK that I won't update my system?

If yes, why?

If no, does it affect the following when updating?

  1. Database
  2. Plugins/Extensions
  3. Created system?

Any suggestions or comments are much appreciated.

migrated from stackoverflow.com Oct 13 '14 at 12:40

This question came from our site for professional and enthusiast programmers.

5

Its upto you.

The updates of any CMS or framework is always good. that doesn't mean your site is not secure or no longer works. The main purpose of software updates are security fixes and more features to the current system.

If you plan for the update it will effect DB,Plugins and extension.

Once you decide to update Joomla 2.5 to Joomla 3.x before that make sure your components/plugins/modules are compatible for Joomla 3.x

Also make sure you are not edited any core files of Joomla, bcoz core file edit may loss with update.

If everything is ok then you can update your current version to latest.

Hope it make sense!

  • your'e welcome.. :) – Jobin Jose Oct 9 '14 at 6:16
  • Obviously it should be said that you should always be at the latest 2.5.x version - at time of writing 2.5.27 for security reasons. 3.x is at your choice as per the answer above – George Wilson Oct 15 '14 at 23:35
-2

Here's my two cents.

Joomla 2.5.X is no longer supported. This means that security issues and other such vital stuff will no longer be addressed.

Since Joomla is in the Opensource domain, every one knows its structure and the assets that Joomla uses.

Hence, whenever a security hole is identified it needs to be plugged immediately. which in the case of Joomla 2.5.X won't happen,

Over time the Joomla sites built on version J2.5.X will becomes very vulnerable.

My advice upgrade to Joomla 3.X.X as soon as possible.

This is easier said than done. Do be careful when migrating Users from J2.5.X to J3.X.X. While the talk is that is seamless that's regretfully not true. The xx_user table structure in J3.X.X has changed, so you will have to manually export your J2.5.X User data, edit the data carefully to map to the J3.X.X and then import the user table data in the Joomla 3.X.X installation.

While this is not rocket science, its tedious and needs to be carefully checked and cross checked.

Also, make a list of all the plugins you've used on the J2.5.X site and figure out which are compatible with J3.X.X which are not.

You are going to have to find equivalent plugins for those that are not compatible and then figure out how they have to be used.

NOTE: Please make really sure that you make a complete backup, folders, files, and database, before attempting an upgrade just in case. Joomla can be quite cussed at times.

All the very best.

  • 1
    Joomla 2.5.x IS supported and will be until decemeber of this year. Security issues are addressed as shown with the ones that came out two weeks ago! – George Wilson Oct 14 '14 at 12:17
  • This is downright wrong , Joomla 2.5 is still supported. – Bogowoe Oct 16 '14 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy