4

On a website I have a template installed which also installed the T3 framework.

Each time I get a notification about an update but when installing an error occurs:

Invalid extension update

All other updates work without any issues. In previous attempts I also tried manually updating. But it did not fix the issue.

enter image description here

  • One click updates never worked for T3. – Valentin Despa Sep 9 '14 at 8:31
  • You could try the JAEM (JA Extension Manager Component) joomlart.com/joomla/extensions/ja-extensions-manager. There are known issues, so JAEM is the recommended way to update T3 - see here joomlart.com/documentation/wiki-ja-extension-manager/… – jonboy Sep 9 '14 at 8:37
  • I would also let the developer know just incase it's a bug within those 2 specific extensions. – Lodder Sep 9 '14 at 17:30
  • I have the problems some times also. What i do is that i download and update t3 framework and template manually. That usally does the trick. – mrleira Oct 21 '14 at 17:31
  • @ValentinDespa This question should be reopened. Answers to this question could be helpful for people with the same problem, for example me. – nbro Jul 8 '15 at 12:13
1
+50

It is very odd indeed. I think the problem comes from the creator. Then, there is nothing else we can do from downstream.

To solve it, just manually download and update it from T3 for Joomla!. At the end of the downloads list, you can find T3 Framework plugin.

1

I went through the changelog on Github and cannot find any references to bug fixes for the extension manager, therefore I don't think it's a big with the extension manager itself.

I believe at the time, it was due to an issue with their update XML file. Either an incorrect download URL or target platform.

What I'd suggest doing is downloading version 2.4.8(template) from Github:

https://github.com/t3framework/t3/releases/tag/v2.4.8

Purge the Joomla cache, and then trying to find an update for T3 again. It should show you one for v2.4.9(template).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.