3

I'm unable to move Joomla! 2.5.4 to another server.

Having built my Joomla site on my local machine, when I upload the site to the live environment (having updated the DB and corrected the settings in configuration.php) Joomla generates this error message when I try to reach the admin console.

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/path/to/administrator/defines.php) is not within the allowed path(s): (/Library/WebServer/Documents:tmp) in /path/to/administrator/index.php on line 12

Warning: require_once() [function.require-once]: open_basedir restriction in effect. File(/path/to/administrator/includes/defines.php) is not within the allowed path(s): (/Library/WebServer/Documents:tmp) in /path/to/administrator/index.php on line 18

Warning: require_once(/path/to/administrator/includes/defines.php) [function.require-once]: failed to open stream: Operation not permitted in /path/to/administrator/index.php on line 18

Fatal error: require_once() [function.require]: Failed opening required '/path/to/administrator/includes/defines.php' (include_path='.:/usr/share/pear:/usr/share/php') in /path/to/administrator/index.php on line 18

The installation is looking for the old path even though I have changed public $log_path and public $tmp_path to the new path in configuration.php

  • 1
    Take a look at Akeba backup as a way of moving sites in future – user248 Apr 29 '14 at 21:54
  • If you have not changed the path to pasted it here "/path/to/administrator/includes/defines.php" is likely to be the path in a tutorial or config that needs updating to your own path – tristanbailey Jun 6 '14 at 3:30
4

I would disable open_basedir, it tends to generate more problems than it solves.

If you need it, make sure the administrator folder is in the allowed paths.

2

I found this on the Joomla Site: http://forum.joomla.org/viewtopic.php?t=710302

Finally got it... I was reading about the "open_basedir" directive. "

Did a locate php.ini and there it was: /home/xxxxx/htdocs/xxxxxxx.net/administrator/php.ini

If you have a php.ini file in this location, change the following two items to the correct paths:

upload_tmp_dir = your path here
open_basedir = your path here
1

You may need to update or remove a RewriteBase statement in the .htaccess file in the root folder of your website.

1

I have seen this happen before on a couple of sites. The first cause is one that is already mentioned with .htaccess/apache config issue.

The other cause I've seen is a caching problem. Try turning off the cache via manually changing the option in the /configuration.php file. You can also manually delete everything in the /cache directory except the index.html file.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.