2

I got a a joomla-powered site. Recently I added an article to the back end, published it but it does not show up on the front end of the website. I went further to 'unpublish' some of the articles that were already showing on the front end. They were still showing on the front end. I have cleared the cache several times, but nothing has changed since. I do not know if anyone has encountered such a similar issue. Will appreciate your responses. Thanks.

  • 1
    Silly question, but are you sure you're managing the article for the correct site? I only ask because I have been know to (when tired) do stuff on my localhost and wonder why it's not showing on my live site. When you say you have cleared the cache, do you mean on your browser or on Joomla? Best thing to do would be to look at the #__content table in the database, and check the published columns to see if your changes have taken effect. 1 = published and 0 = unpublished – Lodder Aug 26 '14 at 11:00
  • Okay,thanks @Lodder. will take a look at the table in the database. And yeah, the cache I cleared is on joomla, not on my browser. – Mekicha Aug 26 '14 at 13:23
  • What are your cache settings? – jonboy Aug 26 '14 at 13:53
  • Currentlyit is set to off. And I changed the time to 0 – Mekicha Aug 26 '14 at 17:18
2

There could be an issue with the date settings in your articles, make sure your dates are correctly set:

  • Start Publishing: Any past date
  • Finish Publishing: Empty, or any future date
  • Created Date: Any past date

I've sometimes copied existing articles and then edit the content, without changing the dates, wondering why my articles don't show up as expected.

Publish Date settings

Also, please make sure your articles are actually saved (maybe obvious, but simply in order to sort out possible errors).

enter image description here

Take a look at Lodders comment too, I've seen this happen before.

  • I already did that but nothing changed. – Mekicha Aug 26 '14 at 13:25
  • OK, I updated the answer with another option, just in case. Have you tried to make other changes, like unpublishing modules, or using the front-end editor to make changes to your articles, in order to see if the changes show up? – johanpw Aug 27 '14 at 20:57
  • Yeah, I unpublished the logo...and the change was updated on the front end.And using the front-end editor, the changes appeared as expected. However I noticed that if i tried to change any settings on the template i am using, it does not also show. In fact, clicking on 'save' produces no action. – Mekicha Aug 27 '14 at 23:47
  • So the save button in your articles (and posibly elsewhere too) is not working at all? Try going to Extensions ->Extension Manager and click Database on the left side. Then click the Fix button. – johanpw Aug 27 '14 at 23:59
  • Thanks, I did that but the problem seems not to go away. On the other hand as @Lodder suggested, I checked the #_content table on the database. The article that is not showing on the front end has a state of 1. – Mekicha Aug 28 '14 at 0:34
2

Check with your web host, they may be caching from the their end. I had that recently happen to me. When I had them remove their cache (which was on by default) I was able to see all of my changes in the front-end.

1

Mihir Chhatre's answer below gave me thought... Check what category you have assigned this article on... And then on the menu-manager, check if the relative menu item that you want this article to appear is set to display articles from this category.

If you are trying to show this article in the front-page and front-page is using a featured articles item, then you need to also set this article as featured and make sure that the menu-item is showing articles from that category.

Lastly, if the page that you are trying to see the article in the front-end is showing articles through any content module, then you will need also to make sure that the module is set to display articles from the category of this article as well.

0

You have to understand that after creating an article it needs to be linked up via a menu to the website.

I feel that since you have no linked the article up to the default menu, it is not being shown on the frontend.

0

If you want publish it on the front page, after created article you must select Featured article, on the another page you must publish it under the category

0

I had the same issue today, I've done the edit and save in Jooma and it just doesn't show in the front end. I clear the cache many times, it doesn't work.

Only when I change the publish date to "today" of the re-editing article and clear the cache again, it works. The front page changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.