1

I have recently transferred my joomla 2.5.6 site over to a new server. The site and the database are both both connected and the files have been transferred but i get a 500 error on 2 separate occasions;

  1. When saving a page after i have updated it or changed any settings (the changes i have made still apply but i get the error screen).

  2. When trying to update the version within the Joomla administration panel.

I have read questions where people mention the error.log but have so far been unsucessful in finding it. Could any one advise me on the best way to find what is causing errors within the site?

  • Are you articles you're trying to save very big? Also, have you ensured when saving an article that the title and/or textarea are not empty? – Lodder Aug 19 '14 at 9:51
  • Could it be a path or permissions issue? Just reading on Joomla docs "tmp directory: An incorrect tmp directory can cause problems. To check this, look in your configuration.php file for the var $tmp_path value and make certain it matches your actual path. This must be writable to Joomla." Just a suggestion? – jonboy Aug 19 '14 at 10:22
  • If error reporting is not correctly set up, you will receive a vague error message (ie 500 error) when the server encounters a problem. More info at stackoverflow.com/questions/11749043/… – TryHarder Aug 19 '14 at 11:01
  • Thank you all for the suggestions. I have not tried to change an article yet its more when i turn extension on and off or edit some html. I have tried turning error reporting on using my configuration.php by setting the value to 'maximum' but still only get a 500 error without any indication of what caused it. – Matthew Proctor Aug 19 '14 at 12:27
2

The dreaded 500 error is the bane of my existence. If your error reporting isn't kicking out anything, the first thing I usually check is the htaccess file to see if it's the problem. In your case, you can still get to things, so I suspect that's not the issue.

The next thing I do is start uninstalling and reinstalling, or upgrading stuff. I've had the Akeeba stuff break a site before and an uninstall-reinstall did the trick. Every so often that also happens with some other extensions.

In a few cases, it's been some tiny plugin somewhere that has somehow gone crazy. At one point I literally did a process of elimination and turned off loads of extensions until either I started to get error messages on the front end or the problem went away.

Also, try setting the error reporting on Development, I think that turns on messages in the back end.

Anyway, I doubt it's a permission issue as much as it is that you've got something that's partially broken in there.

Are you running JCE? if so, try reinstalling or disabling it to see if that's the issue). I recently had this issue with a site when we upgraded JCE before upgrading the joomla core. JCE didn't like that at all. I ended up pulling a backup of the site, dropping it into MAMP and then upgrading the core first, then upgrading other parts after. I broke the site several times till I finally got it right.

Hopefully these tips will be helpful in figuring it out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.