1

I moved one of my site to new domain. And also upgraded it to joomla3. i have around 200 articles/tips displaying using k2. Before moving to new domain google was indexing site well and i was getting around 100 unique visitors per day. But after moving it seems somewhere wrong in indexing for which visitors are coming very less around 5 each day by google. I checked everything like index, follow in global configuration, also in k2 parameters->advanced - "Advanced SEF Settings" tab, i set "Use the item ID in the URL
" to "No" and likewise others to make urls more search engine friendly but visitors from google not increasing as before.

Also one thing i noticed when searched in google typing site:mysite.com, i am seeing article urls indexed as -

http://mysite.com/tips/jquery-javascript/how-to-show-tips-when-clicked-using-jquery-and-qtip/138-how-to-show-tips-when-clicked-using-jquery-and-qtip

instead - http://mysite.com/tips/jquery-javascript/how-to-show-tips-when-clicked-using-jquery-and-qtip

This last one is the expected url i am seeing when i load article via the site and also in http://google.com/webmasters/tools/ sitemap url as i submitted sitemap with this kind of url formation.

So why google indexing urls with multiple title and adding number(138 as above) ?? this may be the reason why google not properly indexing my site and multiple urls being indexed.

4

First off, you have duplicate content (which as you have noticed is hurting your rankings), even though it is using the canonical attribute. I Googled your site, and both links lead to the same exact page.

Make sure you heave it set up like this in K2 http://www.pixelfire.com.au/images/blog-images/K2-settings.jpg ;)

Second, you didn't mention when moving, that you did a 301 redirect on the old domain name for all of the "good" SEO juice content. That means the most visited pages, the most linked pages (if you have an option actually all of them) etc. This is really important. if you don't know how to do a 301 redirect, just follow the below example:

RewriteEngine On

## Begin - Custom redirects

RedirectMatch 301 ^tips/something http://www.newsite.com/tips/something

## End - Custom redirects

You can also find the most visited pages by using Google webmaster as you are already doing.

  • i already have those settings you mentioned in the image. It has been more than 3 months since i moved site. But did not do 301 redirect in .htaccess but all i did in old site is set robots value to "no index, no follow" and put old site offline. Do u think setting this in old site .htaccess file is the solution? I just need to know why google taking urls as double titled instead what i clearly submitted in sitemap and how google indexes k2 item url?, wish i could construct k2 url not as double titled by default so that google don't take it(something like that). – dev-m Aug 4 '14 at 21:16
  • 2
    When you move a site to new domain, you lose all rankings you had on the old domain if you don't do a 301 redirect of the content. It is really important and is the biggest issue to why you are losing traffic. Check up on 301 redirects and do it asap (if you kept the url syntax the same as on the old site (only new domain name) you can use wildcards in 301 redirects). As for the k2 problem, I have yet to recreate it, that's why I cannot help you further with it. Btw, check out the code on your website, under your "main" article it lists a canonical ref and a link to the 18-etc... – Zian Aug 4 '14 at 21:30
  • sorry about u said - "under your "main" article it lists a canonical ref and a link to the 18-etc..." ? when i load k2 articles list or single item in site i don't see link of double titled url of the article. – dev-m Aug 4 '14 at 22:45
  • under all the meta tags and the title there is this: <link rel="canonical" href="mysite.com/tips/jquery-javascript/…">. – Zian Aug 5 '14 at 16:34
  • It's bit difficult to set canonical url for k2 items correctly. I just found out this plugin - joomla-seo.net/SEO-extensions/canonical which actually not letting canonical url to be set. As did not find any fruitful extension for k2 yet to set canonical right way. – dev-m Aug 5 '14 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.