2

I have a Joomla K2 site (all latest versions) and I have noticed that google is finding URLs like this one : http://mysite.com/tag/some-defined-tag.html

Problem is, that gives 404 error because Joomla doesn't know which component that URL belongs to.

Tags do work if they are appended to some page that has K2 component enabled like this: http://mysite.com/some-k2-category/tag/some-defined-tag.html.

Now, the main mistery is, how the hell does Google even find those links. I was looking all over the page and there was never such link that isn't connected to some category.

Is there some way I can fix this to actually lead to a proper page that displays all tagged content without 404 error?

[Edit] I have found out that my tag cloud is generating those non functional URLs but that wasn't the case before I have turned on SEF URLs. Any ideas on how to fix this?

  • I had the exact same problem with the Joomla native tags joomla.stackexchange.com/questions/3772/… – DesignSubway Jul 30 '14 at 20:13
  • i have the same issue, in my case probably is some fault by sh404sef extension i don't know how to resolve that.. – user7497 Dec 22 '15 at 16:00
1

Have you tried modifying the K2 options for SEF? Should work with 2.6.5+

directions: Go to Components / K2 Click the Parameters button top right A window opens up - click the Advanced tab Scroll down to Advanced SEF Settings Enable advanced SEF for K2 URL's - Yes Use the item ID in the URL - No

Not entirely sure it will help your specific issue but place to start.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.