2

I have been noticing that my Joomla admin account has randomly been losing some of it's assigned user groups. A few times it even lost its Super User user group.

Anyone ever experience something like this and have any ideas what could be causing this to happen?

The main components on my site are JomSocial 3.2.1.2, Akeeba subscriptions and EasyDiscuss.

My account wasn't created through Akeeba so I don't think that should affect my account.

I notice this happening either when I log into JomSocial and notice that I can't see the members only content. It has also happened when logging into the backend, the extension manager has been unavailable two or three times. I had to log in as a second Super User account that I had (luckily) and reassign the group.

//July 28th 2014

I have uninstalled Akeeba Subscriptions and purchased this extension. I created a new user through the new extension and am still experiencing the same loss of user group. It is happening with non super user accounts also. Any other ideas what could cause this?

  • It loses and later it re-gain them? How did you realize this? Are there any possible extensions that deal with user assignments to usergroups? Please consider to add more information about your website and its setup, and a more extended description about the issue (when this happens, how are you dealing with it when it happens, etc). – FFrewin Jul 24 '14 at 14:14
  • This is most likely being caused by an extension that manipulates/deals with Joomla's usergroups. As @FFrewin said, you will need to provide a little more information and you should also ensure you're running the latest version of all extensions being used and your Joomla system. – Lodder Jul 24 '14 at 15:30
  • @FFrewin , it doesn't regain the user group. I have to log in myself as a secondary super user account that I have and reassign the group to my user – nico Jul 25 '14 at 12:33
  • @nico Could you add version information for Jomsocial etc to your question please? – TryHarder Nov 12 '14 at 23:33
  • @moomoochoo I am on JomSocial 3.2.1.2 – nico Nov 14 '14 at 17:56
3

Akeeba subscriptions is the most probable cause since it can manage user groups associated with subscriptions.

For instance, if you have tested memberships with the admin account, Akeeba subscriptions is going to assign or unassign the user to groups according to the tested memberships and expirations. Moreover, it's always better to test with simple registered users (not administrators). In some cases, a test works for the admin user (e.g. a super user can access any restricted resource), but not for simple registered users.

If this is the case, you can manually cancel that subscriptions, and finally assign the user to the right groups.

  • The thing is I never test the Akeeba with my Super User account, all of my user groups I assigned myself manually. For now I'll only use the front end as a normal level user that I did create with Akeeba and hopefully I will not notice this happening any longer. – nico Jul 25 '14 at 12:30
3

It turned out to be a JomSocial bug!

The developers have told me that they are working on it and will have it fixed shortly...

  • Do you know if this has been fixed yet? If yes, at what version? – TryHarder Nov 14 '14 at 23:22
2

When you are missing your usergroups, are these groups still in the database? Look in the right tables of your Joomla Database! Iam sure that the groups are already there!

  • The table being affected is the user_usergroup_map so it's the user's losing the groups that have been assigned to them. JomSocial is causing this bug to happen when it's router is being executed! Other JomSocial customers have also complained of this bug and now the development team says they are working on it – nico Aug 14 '14 at 13:52
0

Joomla developers say: As the only people who have confirmed this are jomsocial users we have to conclude it is an issue with jomsocial. I am closing this at this time. If more information is provided to show that the issue is in the core of joomla it can always be reopened.

http://issues.joomla.org/tracker/joomla-cms/5221

EDIT: It is NOT jomSocial issue JomSocial devs actually provided the fix for Joomla that Joomla guys do not want to accept, and still neglect the error http://issues.joomla.org/tracker/joomla-cms/5144

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.