8

Upon installation of Joomla the process stops while creating tables. Some tables were created, but not all of them. So far this only happens with MySQL with Joomla 3.x. What should I do?

  • Did you check the mysql logs for any error messages? – user101289 Apr 26 '14 at 16:44
4

Installation of Joomla requires a properly configured infra. It looks like several stacks are not properly configured out-of-the-box for this very common Joomla setup.

Increase max_execution_time in php.ini and restart apache untill installation of Joomla succeeds. Installation should continue creating the tables and finish in a timely fashion.

| improve this answer | |
  • On w8.1 xampp 181 changed from 30 to 300 and issue resolved – sovainfo Apr 26 '14 at 19:54
  • If that resolves your questions, then please select answer as correct so this question is solved. – garth May 21 '18 at 1:42
3

I had this happen on my XAMPP on a (rather slow) laptop. Basically the script times out while waiting for MySQL. Increasing max_execution_time solved the issue for me.

| improve this answer | |
2

Change the storage engine from InnoDB to MyISAM in installation/sql/mysql/joomla.sql.

See administrator/components/com_admin/sql/updates/mysql/3.0.0.sql for ALTER statements to change the engine back to InnoDB after install.

| improve this answer | |
  • Please don't. The two work different enough that there might be weird, hard to debug, issues later on. Code that assumes InnoDB might do weird things on MyISAM tables. This is because InnoDB is transaction safe and MyISAM is not. – Ville Niemi Feb 2 '15 at 8:30
  • If you are editing the sql-files, you can also use phpmyadmin or something to commit the remaining changes manually. It is bit of bother, but not difficult, so it may sometimes be easier than changing execution time and trying again. – Ville Niemi Feb 2 '15 at 8:37
  • Currently Joomla doesn't use transactions. The requirements mention that InnoDB is required. See the update for 3.0.0.sql for changing the engine back. Advice against messing with phpMyAdmin, there is no reason for installation to fail. – sovainfo Mar 5 '15 at 13:43
1

I also had same problem. Then I found the solution to do some configuration changes in my php.ini file and joomla's mysql file.

The Problem may be occurring because of following reasons -

1. PHP timed out.

Look at your php error log and it should make this error fairly obvious.

So edit your php.ini file, Go to the directory where php is installed and then find the php.ini file and find the parameter

max_execution_time = 30

And change it to

max_execution_time = 200 

Then restart Apache.

Once the install has completed go back and change it back to a value no more than 60.

2. Engine Type

To fix this problem, go to

Joomla_root\installation\sql\mysql\Joomla.sql

replaced all the occurrence of ENGINE=InnoDB with ENGINE=MyIsam

MyIsam is more supported and compatible with Joomla.

Do also the same with (sample_data.sql) file, if it's quickstart setup.

| improve this answer | |
0

You should locate php.ini in C:\xampp\php or C:\wamp\bin\php\php5.5.12 and change memory_limit = 512MB and max_execution_time=300 after that you need to go C:\xampp\htdocs\user\installation\sql\mysql then open joomla.sql or something.sql and then find all ENGINE=InnoDB and change them to ENGINE=MyIsam.

| improve this answer | |
  • 1
    Why would you use MyIsam instead of InnoDB? – Lodder Apr 13 '15 at 19:29
0

I too faced the same issue of hanging of the installation of joomla 3.4.5 on my windows machine.

OS: Win 8.1 x64
XAMPP v3.2.1
Joomla: 3.4.5

I tried to perform the same 5-6 times. Then, after googling a lot came to conclusion that it can be resolved just my modifying 2 parameters in the php.ini config file usually located inside the

<XAMPP_INSTALL_DIR>/php/php.ini

memory_limit = 512M
max_execution_time = 200

It worked. So, there is no need to modify the InnoDB engine to MyIsam. Base installation works well. Just the issue with our default settings of the php configuration.

| improve this answer | |
0

I use XAMPP for Joomla, all I did was to change the max_execution_time=30 to max_execution_time=3000; it worked!

Procedure:

  • Go to C:\xampp\php and open the php.ini file
  • Press ctr+f and type max_execution_time, this will locate the syntax line
  • Change the value from =30 to =300
  • Save php.ini

You must restart apache/xampp, and then try the Joomla installation again.

It will work. Hope that helps.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.