1

I'm working with Joomla today, but I'm stuck at something. I'm using FaLang to translate the site, and everything is working fine. The content and the menu item's are showing properly. But the menu item alias is not translated, though I filled in the field. It's still in it's default language when I hover it to see the link. Is there some setting I didn't see? I think I searched through the whole system. For the menu I'm using the extension DJ-Menu. I can't update the plugin because it has been bought more than six months ago.

Versions:

  • Joomla: 2.5.21
  • FaLang: 1.2.0
  • DJ-Menu: 1.7.3

I hope anyone recognises this (bug?) and can help me. Thanks a lot!

2

Assuming you have setup the menus correctly, this may just be a simple case of a plugin conflict as Falang needs a higher priority

This case can happen with a conflict with another system plugin (maybe the DJ-Menu).

GO to

EXTENSIONS -> PLUGINS

Find the FALANG plugin (type system)

Set the falang plugin to an ordering value of -1 and save the order and see if this solves the problem (empty your JOOMLA cache before reloading pages)

EDIT more info on plugins

Ordering should be a text field as you can manually just type in numbers and click save. This may be different if you have a custom admin template

View your list of plugins, filter the list by SYSTEM

enter image description here

Click ORDERING to put the plugins in ordering order

enter image description here

You should NOW be able to type in -1 and click the little SAVE DISK icon next to the word ordering.

enter image description here

Alternativly, click ORDERING so you are again using the ordering fuction and just use the blue arrows to manually move the FALANG plugin to the top. The system, should then assign ordering numbers autmoatically.

The end result you need is the FALANG to be first in the list when you put things in ORDERING order

  • When I go over there, the extension has already the ordering 0. I can't change it to -1, it's a select box. – Bart Wesselink Jul 21 '14 at 10:08
  • Updated answer with step by step andscreen shots to make sure we are on the same page. If My screens dont look like your screens, you may have a custom Admin Template – MOLEDesign Jul 21 '14 at 13:06
  • Thanks for the detailed answer, but it didn't help. Thanks for your help. – Bart Wesselink Jul 21 '14 at 13:57
  • Sorry to hear that! Next I would temporarily disable any other menu related plugins except FALANG and see what comes out the woodwork. DJ does look like its kept up to date, so doubt that is your cause. Is there any chance that Joomla's multilingual facility has been enabled and that is overruling Falang. I dont know a lot about Falang to comment sadly, since multilingual support is now fully integrated into Joomla, I moved away from all third party translators – MOLEDesign Jul 21 '14 at 21:04
  • I'm working on another project right now, there works another person on it right now. I'll send him this link. Anyway, thanks. – Bart Wesselink Jul 25 '14 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.