3

I try to install Joomla 3.3.1 on a new site, with PostgreSQL database.

I did all correctly, and I tried many times, did lot of verifications, etc, and I have always the return :

"Impossible de se connecter à la base de données. Le connecteur a renvoyé le numéro : Error connecting to PGSQL database."

The host provides PostgreSQL, but they said me that it is few employed.

I asked the host 2 days ago. I think that they tried to do something, but I have no return at all. In the same time, we were in Week-end, and today is National-Day, here. But, if there is a problem in Joomla, I prefer not to wait more longer.

Many thanks for your help.

(I also red this thread : Can I use PostgreSQL with Joomla 3.3 ).

  • Even though Joomla officially supports PostgreSQL, it's recommended you do not use it. There are still a few bugs and the community support for it, to put it bluntly is crap as not many people use it. In addition to this, most extensions do not support it so you're going to find it very hard to get what you want. You should just stick to using MySQLi – Lodder Jul 14 '14 at 14:51
  • Thanks for you answer : I do understand very well ! So do you think that the community support may be interested by a PG/Joomla tester more ? I have a double project, and it is possible, for me, to give the second one for testing. – catherine Jul 14 '14 at 19:12
  • I don't think Joomla users will want to do major testing with PostgreSQL as MySQL is simply 10x more popular and widely used. – Lodder Jul 14 '14 at 19:19
  • Yes, of course, but this system may be more interesting for some applications. – catherine Jul 14 '14 at 21:13
2

Unfortunately the installer does not return the real error.

Here are some general tips:

  • make sure the provided database already exists
  • check if your database needs some specific settings, such as a different port or sslmode=require

Put your connection details in a normal php file and run the script, having error reporting enabled:

<?php
$connection = 'host=127.0.0.1 port=5432 dbname=joomla3 user=postgres password=postgres';
$dbconn = pg_connect($connection);

var_dump($dbconn);

When running the script you might get a proper error. When you get a resource, the connection is successful: resource(4) of type (pgsql link)

  • Thank you : I think that the database exists, but you're right : i have to ask, clearly ! I must wait for tomorrow, for that. For the second part, i have t read more, and study it ! i am not a geek ! Thanks. – catherine Jul 14 '14 at 19:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.