3

I'm new to Joomla! extension development, and I'm a little confused about the manifest XML file. What's the correct way to use these three version tags at the beginning of the XML file?

<?xml version="1.0" encoding="utf-8"?>

<extension version="2.5" type="plugin" group="content" method="upgrade">

<version>1.0</version>

12

First version tag specifies the xml version. Please refer W3 standards for XML

Second version tag identifies the version of Joomla for which this extension is developed.

And third version stands for the version of this extension.

Refer Joomla Manifest for details.

  • Also note that won't need to change <?xml version="1.0" encoding="utf-8"?>. It's only the other version numbers you will need to take into consideration ;) – Lodder Jul 11 '14 at 9:51
  • So the <extension version="2.5"... is the minimum version the extension will work in (as in 2.5 and above, including 3.x)? Can I specify an extension only compatible with 2.5 and not 3.x (pure curiosity...)? – johanpw Jul 11 '14 at 12:41
  • Well it indicates the minimum joomla version supported by the extension. You can not specify not supported joomla version here. – Nick Jul 11 '14 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.