2

We developed multiple extensions for our clients, but none of them are published on the JED. We also do not want to publish to the JED since they are custom extensions.

All our extensions always show up on the Joomla Update Screen under: Update Information Unavailable

We want them to show up under: No Update Required or Update Required

So we need to add compatibility information, but we can't find information about this.

Can anyone point us in the right direction, please.

As example our extension .xml files are like this:

<?xml version="1.0" encoding="utf-8"?>
<extension type="module" version="4" client="administrator" method="upgrade">

...

  <version>1.5.2</version>

...

</extension>

I tried to keep it as short as possible if more information is required I am happy to provide it.

1 Answer 1

4

In your manifest .xml file for your extension(s) you can specify the <updateservers> element that provides a link to your own website that contains a .xml file that has details about your extension and whether there is a new release or not.

Towards the bottom of this page you can find details on the <updateservers> elements https://docs.joomla.org/Manifest_files and further links to describe the contents of the .xml file per extension. There is also this page on Update Servers that might help you, https://docs.joomla.org/Deploying_an_Update_Server.

To answer the compatibility question the <targetplatform> element of the .xml file on your update server is used to indicate whether the extension is compatible with the current Joomla instance.

There is nothing there yet, but this page in the Joomla Programmers manual might help someone who finds this post in the future, https://manual.joomla.org/docs/building-extensions/install-update/update-server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.