0

In my XML script of my extension for the Joomla! updater, i need to allow the updates when the extension is installed on : Joomla! 4.3.x, 4.4.x and 5.0.x. I have set in my XML file the targetplatform like that but it allow the update only on Joomla! 5.0. I have added recently the support for Joomla! 5.0

<targetplatform name="joomla" version="4.(3|4)|5.0"/>

What is the correct way to do it ?

1
  • 1
    After i have made others checks on Joomla! 4.3.4 and Joomla! 5.0, it works like that Oct 23, 2023 at 12:46

3 Answers 3

1

Try this one

^(4\.([3-9]|10)|5\.([0-9]|10))\b

Feel free to change the range of supported versions.

1

After to have re-checked it works by doing that :

<targetplatform name="joomla" version="4.(3|4)|5.0"/>
0

i‘ve simply changed to .* for compatible extensions. its not the best way but the best i could find so far…

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.