0

When I go to content > media, I don't see anything and cannot upload images or make folders. There is the error: "Property 'mime_type' of argument 'item' of event onFetchMediaItems has a wrong item. Valid: string".
I found a possible solution could be to enable the fileinfo PHP extension. I did it but it didn't help. Php settings tab (on Joomla System information) says 'Fileinfo Available: No'. So, if it is enabled on cPanel, how to make it available to Joomla?

New update: I checked with the hosting provider and got this answer: "It is NOT possible to change PHP settings from the php.ini file at the server level. If you need to change the php.ini settings, create your own php.ini file in the directory where the script that requires such changes is located."

I created php.ini file in Joomla root folder, added this line: extension = fileinfo.so

It didn't help. Any ideas?

10
  • 1
    I had the same message last week and enabling fileinfo did resolve the issue. Have you confirmed that the` fileinfo` is actually available by going into System Information and then the PHP Information tab of your Joomla installation?
    – Irata
    Sep 26, 2023 at 23:10
  • This is a duplicate of joomla.stackexchange.com/q/32569/120 Sep 27, 2023 at 2:04
  • @NeilRobertson, it's not really a duplicate. That solution didn't help me. I'm posting here for the first time so I don't know if is it custom to follow the rules or not, but when I wanted to comment on that topic, these rules showed up: " Please be sure to answer the question. Provide details and share your research! But avoid … Asking for help, clarification, or responding to other answers." so I started new topic.
    – Silvija
    Sep 27, 2023 at 8:57
  • @Irata when I look at cPanel PHP Selector it looks enabled. In System Information... I'm not sure. Fileinfo is mentioned twice: 1) in Configure Command '--enable-fileinfo=shared' (among others) 2) in SPL > Classes > SplFileInfo (among others)
    – Silvija
    Sep 27, 2023 at 10:10
  • In my Joomla 4 under PHP Information I see a line under the heading "fileinfo" that shows 'fileinfo support enabled '. The heading is between 'exif' and 'filter'
    – Irata
    Sep 27, 2023 at 10:33

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.