1

There's a broken Joomla installation in the host (not made by me) as far as I read, it's because it doesn't work with PHP7+.

I'd like to make a fresh install and reuse the database that the broken installation is currently using. Can this something work?

I have no experience with Joomla, I'm just trying to fix this. Any other suggestions are welcome.

Part of the log error goes like this:

[24-Jul-2022 08:09:11 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 08:29:46 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 10:23:17 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 10:24:11 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 10:42:23 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 11:24:11 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 11:24:16 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 11:24:16 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 14:54:34 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 15:46:42 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 18:50:16 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 19:45:00 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 20:11:38 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[24-Jul-2022 20:30:40 America/Chicago] PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1650 but version 1654 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
[18-Oct-2022 13:25:43 America/Chicago] PHP Fatal error:  Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home1/pegasena/public_html/old/joomla_site/includes/framework.php:21
Stack trace:
#0 /home1/pegasena/public_html/old/joomla_site/index.php(22): require_once()
#1 {main}
  thrown in /home1/pegasena/public_html/old/joomla_site/includes/framework.php on line 21
[18-Oct-2022 13:25:46 America/Chicago] PHP Fatal error:  Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home1/pegasena/public_html/old/joomla_site/includes/framework.php:21
Stack trace:
#0 /home1/pegasena/public_html/old/joomla_site/index.php(22): require_once()
#1 {main}
  thrown in /home1/pegasena/public_html/old/joomla_site/includes/framework.php on line 21
[18-Oct-2022 13:34:47 America/Chicago] PHP Fatal error:  Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home1/pegasena/public_html/old/joomla_site/includes/framework.php:21
Stack trace:
#0 /home1/pegasena/public_html/old/joomla_site/index.php(22): require_once()
#1 {main}
  thrown in /home1/pegasena/public_html/old/joomla_site/includes/framework.php on line 21
[19-Oct-2022 12:40:44 America/Chicago] PHP Fatal error:  Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home1/pegasena/public_html/old/joomla_site/includes/framework.php:21
Stack trace:
#0 /home1/pegasena/public_html/old/joomla_site/index.php(22): require_once()
#1 {main}
  thrown in /home1/pegasena/public_html/old/joomla_site/includes/framework.php on line 21
1
  • Can you provide more details, in particular what version(s) of Joomla are you dealing with here and what levels of PHP and MYSQL are you coming from and try to go to. From the messages you appear to be using a version of Joomla that doesn't support being run on PHP 7. So is the site broken when run on a PHP 5.x environment? Certain versions of Joomla require a migration to move to the next version therefore dropping an old DB under a newer install would not work or solve your problem.
    – Irata
    Oct 27, 2022 at 2:39

2 Answers 2

1

The PHP function set_magic_quotes_runtime that is visible in your error message has been DEPRECATED as of PHP 7.4.0, and REMOVED as of PHP 8.0.0, see https://www.php.net/manual/en/function.get-magic-quotes-runtime.php

The Joomla documentation has some info about upgrading: https://docs.joomla.org/Portal:Upgrading_Versions

1

You may be able to add a directive to the .htaccess file in the root folder of the website to set the PHP version back to 5.6 or similar e.g.:

AddHandler application/x-httpd-php56 .php .php5

Alternatively, the files and database could be backed up and restored to an alternative host running an older version of PHP.

Once the website is on a compatible version of PHP, you can then upgrade third party extensions and Joomla so they are compatible with PHP 7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.