3

Repo of component: https://github.com/Joomla-Bible-Study/Proclaim

We have been converting our component to Joomla 4 standards and have run into a problem with it installed on some hosts, and non of the View will load. We can't figure out what makes the system not load on the site.

Tested different versions of PHP

An error has occurred.
404 View not found [name, type, prefix]: CWMCpanel, html, Administrator
Call stack
#   Function    Location
1   ()  JROOT/libraries/src/MVC/Controller/BaseController.php:816
2   Joomla\CMS\MVC\Controller\BaseController->getView() JROOT/libraries/src/MVC/Controller/BaseController.php:602
3   Joomla\CMS\MVC\Controller\BaseController->display() JROOT/administrator/components/com_proclaim/src/Controller/DisplayController.php:50
4   CWM\Component\Proclaim\Administrator\Controller\DisplayController->display()    JROOT/libraries/src/MVC/Controller/BaseController.php:672
5   Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/libraries/src/Dispatcher/ComponentDispatcher.php:143
6   Joomla\CMS\Dispatcher\ComponentDispatcher->dispatch()   JROOT/libraries/src/Component/ComponentHelper.php:355
7   Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/AdministratorApplication.php:143
8   Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT/libraries/src/Application/AdministratorApplication.php:186
9   Joomla\CMS\Application\AdministratorApplication->doExecute()    JROOT/libraries/src/Application/CMSApplication.php:294
10  Joomla\CMS\Application\CMSApplication->execute()    JROOT/administrator/includes/app.php:61
11  require_once()  JROOT/administrator/index.php:32

We have looked around other systems and don't see where we have gone wrong, so we could use some help finding the error in our ways. The system is in Alpha state, and we want to test on other hosts to verify things.

4
  • Have you ensured all of the correct PHP modules are installed? Do you have a link to the live/dev site please?
    – Eoin
    Sep 27, 2022 at 17:22
  • I know you have probably checked this but it's better to go over everything step by step. It's looking for this view: CWMCpanel. Does that view definitely exist? The file isn't missing? The case of all the letters is ok?
    – Eoin
    Sep 27, 2022 at 17:24
  • The errors we are hunting down are on the admin side. I have not worked with the site side yet. You can see all the code here at link. Live link to admin. I'll have to make a login for you to use if needed. Sep 27, 2022 at 17:56
  • I've dug deeper, and all I can find is it's not loading the classes from a namespace into Joomla. Sep 27, 2022 at 22:08

1 Answer 1

3

HtmlView.php is case-sensitive. Also, all other files within the src folder for namespacing are case-sensitive.

That is what was causing all the problems.

2
  • 1
    I had this exact problem yesterday after I tried to install the component I've developed on Xampp (Windows environment) onto a web server running on Linux. I was tearing my hair out trying to figure out what was going wrong, but I had earlier fixed an error caused by one of my classes having a single incorrect capitalisation. I noticed that it hadn't affected my local install, but it took me a while to connect the dots and realise that case sensitivity might be causing wider issues. A session of renaming classes, folders and namespaces and all was eventually working in the new location :)
    – Grant Hood
    Sep 28, 2022 at 8:41
  • 1
    Thanks for coming back and leaving the answer that's very helpful. Hopefully my comment gave you a tip on how to find that. I couldn't say why it didn't cause an issue on the original localhost but now you know, go forth, educate the masses (did you like my pun?)
    – Eoin
    Sep 28, 2022 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.