2

I am trying to upgrade my development server from 3.10.11 (which works fine) to 4.x in preparation for Joomla 3.x going out of support in August 23.

When I do run the live update, I get an alert box in my browser saying that the server was unable to write the file:

/var/www/html/api/components/com_banners/src/Controller/BannersController.php

This is the first file in alphabetical order that doesn't exist on the server. So I assume that in some way the apache user (the user that my web server runs as) isn't able to create either a new file or a new directory in that folder.

The owner:group of the folder /var/www/html is apache:apache and I have tried setting permissions to 775, but I still get the same message.

Normally as I am running fedora I would expect selinux to be the culprit of this kind of error but running setenforce 0 doesn't help.

I am fairly sure this isn't a Joomla issue so much as that I have misconfigured my server somehow. That said I can't work out at all what the issue is.

1 Answer 1

3

The issue turned out to be the extension RSFirewall for Joomla By RSJoomla.

To solve the issue I added an 'exception'.

I specified that the component named 'Joomla! Update' could bypass all aspects of the firewall.

After that I was able to use the live update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.