1

Joomla 3.10.11

I cannot find the settings for this. I have been experimenting with the native search, smart search and an extension for advanced search. We are most happy with the results from smart search but it is missing the articles from a content category we created... we have products, faq, etc all the articles from these categories show up in search results. the articles from the category Producers dont. I suspect this is due to some display setting I didnt add this particular category to, but I cannot find it. I also cannot find where to set the number of article results per list page.

I have disabled the regular search plugin. I looked through the menu items, components and plugins and options for smart search. I have confirmed my smart search index contains the articles for the category. When I enable regular search the category articles appear. they are published etc.

I feel like there must be a set of options somewhere I am missing that control both the result numbers and layout (like a normal category blog page) and what categories to search in. What am I missing???

2
  • Could you please clarify what you mean by "it is missing a category"? Are you referring to the category filter of the Smart Search or the category that is displayed in each result item?
    – Sakis
    Aug 29 at 14:23
  • I just edited. thank you. the articles of one specific category that are displayed in the results. the articles from that category don't appear in the results in the frontend, but they are in the index.
    – user16561
    Aug 29 at 18:21

1 Answer 1

0

Go to Smart Search > Content Maps and check if these articles are published. You should see a green box beside your category with the number of the pubslihed articles.

Make sure that the category is published and it's articles too, under the content maps.

1
  • Yes, its all there and published. i have 77 articles under "Producer" they all have a green checkmark when i click the green box that has the 77 number in it. just so weird...
    – user16561
    Aug 30 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.